/usr/bin/install failure with SVN

/usr/bin/install failure with SVN

Postby thefirstm » 08 Jan 2010, 15:57

I am attempting to build a Debian/Ubuntu package of the latest SuperTuxKart SVN, but I am having a problem that causes the build to fail with the following error:

/usr/bin/install: will not overwrite just-created `/tmp/buildd/supertuxkart-0.7~svn4417/debian/tmp/usr/share/games/supertuxkart/data/tracks/jungle/materials.xml' with `./jungle/materials.xml'

I was wondering what, if anything, I might be doing wrong and how to fix this error. Thanks!
thefirstm
 
Posts: 5
Joined: 08 Jan 2010, 15:53

Re: /usr/bin/install failure with SVN

Postby Auria » 09 Jan 2010, 03:24

Hi there,

indeed the autotools build system has been barely kept working during development (Hiker is using Visual Studio as build system, and I am using Xcode). So it is sort of expected that 'make install' would fail. I don't believe I know enough about autotools to fix that. Patches are gladly accepted, but anyway this will surely be fixed by a [stable and probably even not-so-stable] release :)
Image
User avatar
Auria
STK Moderator
 
Posts: 2976
Joined: 07 Dec 2009, 03:52

Re: /usr/bin/install failure with SVN

Postby thefirstm » 09 Jan 2010, 13:20

I know absolutely nothing about autotools, so I don't think I can fix it myself. I am not quite sure what the error even means.
thefirstm
 
Posts: 5
Joined: 08 Jan 2010, 15:53

Re: /usr/bin/install failure with SVN

Postby hiker » 10 Jan 2010, 11:46

thefirstm {l Wrote}:I know absolutely nothing about autotools, so I don't think I can fix it myself. I am not quite sure what the error even means.

I'll have a look tomorrow, we need this to work when we do an alpha release anyway.

Cheers,
Joerg
hiker
 
Posts: 1435
Joined: 07 Dec 2009, 12:15
Location: Melbourne, Australia

Re: /usr/bin/install failure with SVN

Postby hiker » 11 Jan 2010, 01:34

Hi,

I think I've fixed it in r4426 - can you give this a try? It worked for me, so I can't verify this. There might be other directories with a similar issue - please let us know of them, so we can fix them all.

Thanks!
Joerg
hiker
 
Posts: 1435
Joined: 07 Dec 2009, 12:15
Location: Melbourne, Australia

Re: /usr/bin/install failure with SVN

Postby thefirstm » 14 Jan 2010, 21:41

Sorry for the slowness. I am trying to compile it now...
thefirstm
 
Posts: 5
Joined: 08 Jan 2010, 15:53

Re: /usr/bin/install failure with SVN

Postby thefirstm » 14 Jan 2010, 21:46

Nope, more failures:

/usr/bin/install: will not overwrite just-created `/build/buildd/supertuxkart-0.7~svn4464/debian/tmp/usr/share/games/supertuxkart/data/bubblegum.projectile' with `./bubblegum.projectile'
/usr/bin/install: will not overwrite just-created `/build/buildd/supertuxkart-0.7~svn4464/debian/tmp/usr/share/games/supertuxkart/data/plunger.projectile' with `./plunger.projectile'
/usr/bin/install: will not overwrite just-created `/build/buildd/supertuxkart-0.7~svn4464/debian/tmp/usr/share/games/supertuxkart/data/cake.projectile' with `./cake.projectile'
/usr/bin/install: will not overwrite just-created `/build/buildd/supertuxkart-0.7~svn4464/debian/tmp/usr/share/games/supertuxkart/data/bowling.projectile' with `./bowling.projectile'
thefirstm
 
Posts: 5
Joined: 08 Jan 2010, 15:53

Re: /usr/bin/install failure with SVN

Postby hiker » 15 Jan 2010, 03:24

Hi,

thanks for the list, found indeed another bug. Could you try again after updating to r4468 (or later), and report any more files that have a problem? That's a bit annoying, but since it works for me I can't easily find them.

Thanks!
Joerg
hiker
 
Posts: 1435
Joined: 07 Dec 2009, 12:15
Location: Melbourne, Australia

Re: /usr/bin/install failure with SVN

Postby thefirstm » 15 Jan 2010, 14:02

Thanks! It compiles just fine now, and runs too. Most of the races I have tried also work, but I have noticed one problem. Antialiasing does not work. (This with the nvidia blob, by the way.)
thefirstm
 
Posts: 5
Joined: 08 Jan 2010, 15:53

Re: /usr/bin/install failure with SVN

Postby Quix0r » 13 Feb 2010, 03:07

Another one: the executable at ./src/supertuxkart isn't copied to the installation folder. I grep for "src" but didn't find something useful. SVN 4704.
Quix0r
 
Posts: 4
Joined: 13 Feb 2010, 01:53

Who is online

Users browsing this forum: No registered users and 0 guests