New way to install on Linux must apply fix for gamepad suppo

New way to install on Linux must apply fix for gamepad suppo

Postby tux_peng » 05 Feb 2018, 03:09

STK has a flatpak for distro agnotic installs on Linux
{l Code}: {l Select All Code}
flatpak install --from https://flathub.org/repo/appstream/net.supertuxkart.SuperTuxKart.flatpakref


Flatpak's do not have direct access to hardware, so fto use gamepads one must
{l Code}: {l Select All Code}
flatpak override --device=all net.supertuxkart.SuperTuxKart
also known as jpenguin
User avatar
tux_peng
 
Posts: 73
Joined: 13 Jun 2014, 19:59

Re: New way to install on Linux must apply fix for gamepad s

Postby deve » 05 Feb 2018, 09:07

AFAIK we don't maintain flatpak builds. And it looks more like a sandbox environment? Anyway it should be possible to declare required permissions in the package, so that you won't need to use override later. But I have no idea who is maintaining it ;)
deve
 
Posts: 226
Joined: 23 Jan 2014, 13:45

Re: New way to install on Linux must apply fix for gamepad s

Postby tux_peng » 10 Feb 2018, 04:50

Yes, it's more of a sandbox. No problem, thought you might want to add this to the FAQ.

IDK who maintains them, all flathub gives is flathub@lists.freedesktop.org
also known as jpenguin
User avatar
tux_peng
 
Posts: 73
Joined: 13 Jun 2014, 19:59

Who is online

Users browsing this forum: No registered users and 1 guest