Dead Ascend - 2D, hand-drawn, point'n'click-ish adventure

Dead Ascend - 2D, hand-drawn, point'n'click-ish adventure

Postby larpon » 26 Jul 2017, 21:17

Dead Ascend


Hey all. I've developed an open source adventure game.
The special thing about it is that all the graphics are hand-drawn - and it is written in ~95% QML (Qt Meta Language) & JavaScript - and a bit of C++ to fill in some gaps. ;)

You can download the source and build the game directly for desktops with Qt Creator

Hope you like it!

Posts: 3
Joined: 26 Jul 2017, 21:02

Re: Dead Ascend - 2D, hand-drawn, point'n'click-ish adventur

Postby farrer » 27 Jul 2017, 22:10

Looks really great.

But I'm having some problems trying to compile it (I never used qt-creator before and I'm not familiar with qml). QtCreator is showing three errors:

{l Code}: {l Select All Code}
at DeadAscend/App/qml/Modes.qml:9: error: Expected token `,'
at DeadAscend/extensions/qak/Qak/Qak.qml:39: error: Expected token `,'
at DeadAscend/extensions/qak/Qak/Qak.qml:41: error: Expected token `}'

Maybe it's a missing dependence?

Edit: Forgot to say that I'm getting a segfault on qtcreator when I click on "configure-project". Maybe this is related.
User avatar
Posts: 87
Joined: 24 Feb 2014, 21:00

Re: Dead Ascend - 2D, hand-drawn, point'n'click-ish adventur

Postby Imerion » 30 Aug 2017, 23:29

Nice! Not often you see finished point & click-adventures with hand-drawn graphics. Will have to give this a go some day!
Try my games! : My Games - Read my FOSS Games Blog! : Free Game News
Posts: 101
Joined: 09 Apr 2011, 19:37

Re: Dead Ascend - 2D, hand-drawn, point'n'click-ish adventur

Postby nanoriver » 31 Aug 2017, 14:55

It looks very interesting and since im a sucker for point n click adventures i think i may give it a try :) Right on ^^
You need a mobile game or a Website? Check us out at
User avatar
Posts: 2
Joined: 28 Aug 2017, 03:26

Re: Dead Ascend - 2D, hand-drawn, point'n'click-ish adventur

Postby enz » 01 Sep 2017, 13:34

Looked interesting enough to try it out. I followed the instructions to build it using Qt 5.9 on Ubuntu 17.04 and it locked up my machine when creating the resource files with the assets. I'm not sure what the problem was because I had to do a hard reboot. Maybe memory (I have 16 GB of RAM). Or that I did a shadow build in an external directory? So I rebooted and changed the build directory to build within the source tree. This time the build completed (using only 60% memory of my 16 GB). I was able to play the tutorial but then the program crashed with a segmentation fault during the first level. Repeating the crash in the debugger showed no location in a C++ file but a hex dump of a binary file. I don't remember more information about the crash because I then deleted the project. I might try it again if it becomes a bit more stable.
Posts: 8
Joined: 29 Oct 2012, 08:47

Re: Dead Ascend - 2D, hand-drawn, point'n'click-ish adventur

Postby larpon » 11 Jan 2019, 10:05

Sorry to hear people had problems building it.
I've finally come around to provide Desktop builds for Linux, MacOS and Windows!

Here you go:
Posts: 3
Joined: 26 Jul 2017, 21:02

Re: Dead Ascend - 2D, hand-drawn, point'n'click-ish adventur

Postby drummyfish » 11 Jan 2019, 14:27

Nice, it runs for me. I would like to put this on the libregamewiki -- the assets are covered by the MIT as well? What about the sounds and music?
Abolish all IP laws. Use CC0.
User avatar
Posts: 33
Joined: 29 Jul 2018, 20:30
Location: Moravia

Re: Dead Ascend - 2D, hand-drawn, point'n'click-ish adventur

Postby Wuzzy » 11 Jan 2019, 19:56

Hi. Parabola user here. I had no problems in building this project, I just followed exactly the instructions and it worked!

I have completed your game. Nice and simple. It's quite short, but I had my fun. It's rare to see hand-drawn stuff in a game, interesting idea! :D Looks like you made it with a pencil. I generally like those “escape the room/house/tower/whatever” type of games, and it's great to see one of them being FOSS as well! So thanks for that! :) As for the game, it's nothing very unique, and sometimes a bit silly, but it was still enjoyable. I played a lot of those short “escape the room” games, I think I know this genre pretty well now. :D
What I didn't like was the lack of sounds effects, that seems like a missed opportunity. :(


I like to report a few bugs:
  • The music does not seem to loop. It just stops after playing once. After that, the game is silent.
  • In the first room, if you patch the bucket and place it under the faucet, you can still see water leaking below
  • Some actions took me several attempts to actually got accepted by the game (which made me go stuck for no reason), even when I made the correct combination:
    • Opening the cabinet with the coin (hinge/screw)
    • Grabbing the elevator button with the flypaper

By the way, I think the most hilarious thing was the zombie hamster. So cute ... I guess?! XD

List of typos:
  • You used the word “tab” (e.g. “tab on objects”) several times, but it should be “tap”. “tab” is short for the tabulator key, I think.
  • Many sentences don't end with a period. Intentional?
  • “Objects you have picked up is in your inventory” → “Objects you have picked up are in your inventory.”
  • “skies” → “skis” (“skies” is the plural of “sky”, not “ski”)
  • “sleeve assembly” → WTF is this?
  • “The flourescent lights humms faintly - casting a grim light in the room...” → “The fluorescent lights hums faintly - casting a grim light in the room...”
  • “There's nothing more downthere” → “There's nothing more down there.”
  • “It's just a matter of finding something powerfull enough to run it” → “It's just a matter of finding something powerful enough to run it.”
  • “It look like a charging mechanism of some sort“ → “It looks like a charging mechanism of some sort.“

Missing features (IMHO):
  • Ability to skip intro with mouse click or key press
  • Sound effects
  • The game should default to the system language and fall back to English if the game does not support that language
  • No “exit” button in main menu

Finally, I like to contribute a German translation for your game, which I provide for you under the MIT License.
I have attached a file at this post. This translation has not been tested, because it seems some code needs to be changed as well.
I added the translation for commit ID 44349ec4498ad198019b78480596bfd97787dfed.

The charging paper still needs translation, but I am unable to understand the sentence “Press play on tape.”. Yes, I solved the puzzle, but I still don't understand this sentence. XD If you can tell me what it means, I will tell you how to translate the charging paper.
German translation (untested!)
(14.17 KiB) Downloaded 2 times
Got too many bitcoins? I gladly take them: 17fsUywHxeMHKG41UFfu34F1rAxZcrVoqH :-)
User avatar
Posts: 635
Joined: 28 May 2012, 23:13

Who is online

Users browsing this forum: No registered users and 1 guest