[PEBKAC] Linux build OpenGL Fun.

[PEBKAC] Linux build OpenGL Fun.

Postby ERIIX » 24 Sep 2014, 12:40

Nevermind. I must be blind. The core profile may be 3.3, but the driver sets the version 3.0 because some features aren't implemented. Since the engine requires 3.2, this isn't sufficient. Seems Mesa 10.3 also returns only 3.0 for the actual version, so getting my (very old) card working in the near future seems unlikely. As for the behavior depending on fullscreen state, I assume calling functions from OpenGL 3.2 on OpenGL 3.0 basically means we're in nasal demon territory. On the upside, I now know http://forum.freegamedev.net/viewtopic.php?f=87&t=5628&p=57491&hilit=light+manager#p57491 was likely caused by an insufficient OpenGL version (though I can't be sure since the paste has expired).

Original message follows for the sake of completeness.

blank.jpg is how the game looked fullscreen, while semiblank-small.jpg is how it looked when I dropped fullscreen to save the screenshot. It shouldn't have make any difference...

I'm using the free Radeon driver. `glxinfo|grep version` results in:
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.2.6
OpenGL core profile shading language version string: 3.30
OpenGL version string: 3.0 Mesa 10.2.6
OpenGL shading language version string: 1.30
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.2.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.0

Despite Mesa returning 3.3 for the core profile, my first attempt resulted in Torque detecting 3.0, which is less than the 3.2 it requires, so it resulted in the "Failed to set a light manager!" message reported in another thread.

I ran again with MESA_GLX_VERSION_OVERRIDE=3.3, since that should be supported (unless we're using GL ES?). The results were rather broken, graphically. The menu worked. In fact, all 2D overlays appeared to work perfectly. The 3D was a different story. When I left fullscreen, I was able to see some effect like a vague outline, as seen in the second screenshot. I suspect it to be the grid. Returning to fullscreen largely removed it.

I'm going to play around a bit on my own to see if it's just a broken system configuration, but I was asked to post the images, so here they are.
Not fullscreen.
Posts: 1
Joined: 24 Sep 2014, 12:09

Who is online

Users browsing this forum: No registered users and 1 guest