Hardware requirements, Debian, ATI

Hardware requirements, Debian, ATI

Postby Snake » 25 Aug 2015, 04:55

Hi,

I have Debian 8.1 32bit on my computer and I downloaded the 32bit tar.xz precompiled binary package from the Stunt Rally site.

I tried running it normally but it didn't do anything so I decided to run it from the terminal to see any errors and I found a couple.
In the terminal I get these errors:
libGL error: unable to load driver: r300_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r300
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast


And at the very bottom it says:
Could not initialize SDL! No available video device


Anyone know anything about this and know how to fix it if possible? Those files for me are in /usr/lib/i386-linux-gnu/dri

Any help is greatly appreciated. I would love to get this game running if possible. My video card is a ATI Radeon 9550 with 256mb vram. I know its a old low end card but I'm hoping it'll run on that without too much lag. Hopefully!

Again, any help is greatly appreciated. Thanks!
Snake
 
Posts: 8
Joined: 25 Aug 2015, 04:17

Re: Can't get game to run. can't find a couple files.

Postby NaN » 25 Aug 2015, 12:47

Just a wild guess, but could be runtime lib conflict.

Is there a libstdc++.so in the package, try deleting it...
https://wirejungle.wordpress.com/2015/0 ... orkaround/
NaN
 
Posts: 150
Joined: 18 Jan 2010, 10:32

Re: Can't get game to run. can't find a couple files.

Postby CryHam » 25 Aug 2015, 18:44

Hmm well.. this card is below our minimal requirements.
TBH, I would be surprised if it could start SR, even at lowest settings, guessing even if then at 15 fps which isn't playable and tracks are empty.
I looked at some specs, it's from 2003 and has just 4 cores.
Hmm but only 4 texture units.. Probably few materials need more.
Seems like a driver issue from that log.
GPU has OpenGL2, so I guess it should start.
User avatar
CryHam
SR Moderator
 
Posts: 695
Joined: 25 Nov 2012, 08:40

Re: Can't get game to run. Debian, ATI

Postby Snake » 25 Aug 2015, 22:38

Thanks. I'll look into that.

BTW, if I can't get it to run, what older version would I need of Stunt Rally to be able to play? I only have a single core CPU. It's a Intel Pentium 4 running at 2.40GHz.


EDIT: NaN, I tried the suggestions on that site and the errors about not loading the files are gone. So we fixed that part....I think.
But at the bottom it still says:

std:: runtime error
Could not initialize SDL! No available video device


The part that says std:: runtime error was present before, I just forgot to include it in the first post. :?

Like I said though, if we can't get this working, is there an older version I can use that'll run on my hardware?

Thanks

Edit2: forgot to mention that I downloaded version 2.5 of the game.
Snake
 
Posts: 8
Joined: 25 Aug 2015, 04:17

Re: Can't get game to run. Debian, ATI

Postby CryHam » 26 Aug 2015, 16:16

Just to be clear if I wasn't:
It's impossible to run SR on such hardware (any version).
User avatar
CryHam
SR Moderator
 
Posts: 695
Joined: 25 Nov 2012, 08:40

Re: Can't get game to run. Debian, ATI

Postby Snake » 26 Aug 2015, 19:41

That sucks

Thanks anyway. And no, you wasn't too clear on your first post. ;)

I downloaded version 1.5 last night and it ran fine but it crashed while it was loading the actual game. It kept crashing on the part where it started loading the car... Something about not finding the cars textures or not being able to load them or something.
Snake
 
Posts: 8
Joined: 25 Aug 2015, 04:17

Re: Can't get game to run. Debian, ATI

Postby CryHam » 26 Aug 2015, 20:21

Yeah, only 4 texture units.
If even car material wants more then surely terrain would crash after.
You could try VDrift, Speed Dreams or STK. Those have much lower hardware requirements.
User avatar
CryHam
SR Moderator
 
Posts: 695
Joined: 25 Nov 2012, 08:40

Re: Hardware requirements, Debian, ATI

Postby Snake » 26 Aug 2015, 22:10

Thanks. I already have TORCS installed. I have STK installed as well and it runs almost perfect.

I downloaded version 1.6 earlier and it runs fine on low settings. Yes, I get no trees and black water/mud and between 15 to 20FPS but for me, that is perfectly playable. I'm happy with it for now. Unti I can get the funds for a new computer. I have a feeling 1.5 will play as well on low settings. Haven't tried yet though.

I've only done single races so far, haven't done a race with other cars yet. Might lag a bit for but whatever.
Snake
 
Posts: 8
Joined: 25 Aug 2015, 04:17

Re: Hardware requirements, Debian, ATI

Postby Snake » 27 Aug 2015, 00:02

You can go ahead and lock this. I'm done with it. I noticed the title has been changed twice. For some reason.
Snake
 
Posts: 8
Joined: 25 Aug 2015, 04:17

Re: Hardware requirements, Debian, ATI

Postby CryHam » 27 Aug 2015, 06:03

Cool.
Yes, I'm usualy changing the topic to state the issue clearly.
User avatar
CryHam
SR Moderator
 
Posts: 695
Joined: 25 Nov 2012, 08:40

Who is online

Users browsing this forum: No registered users and 1 guest