Crash with Integrated GPU, Mobile, Mesa

Crash with Integrated GPU, Mobile, Mesa

Postby eaoden » 12 Nov 2014, 18:17

Hello everyone,

My name's Antoine-Frédéric, a French user who experiences a crash after the loading screen.

I use an Nvidia GEFORCE GT 635M and a quad-core intel i7 CPU.
I'm running this on my Manjaro KDE distribution which I upgraded yesterday to the last release.

I also have to say that I downloaded Stunt Rally via yaourt ("yaourt -S stuntrally").

I downloaded the gdb package and ran it, although I had no stuntrally-dbg package. The crash didn't happen ; the window froze on the loading screen. Anyway, here is the backtrace I got :

{l Code}: {l Select All Code}
(gdb) bt
#0  0x000000000069d0a8 in MyGUI::delegates::CMultiDelegate2<MyGUI::Widget*, unsigned long>::clear() ()
#1  0x0000000000681ebe in CGui::InitGui() ()
#2  0x00000000006ed05c in App::createScene() ()
#3  0x0000000000618f83 in BaseApp::setup() ()
#4  0x000000000061a553 in BaseApp::Run(bool) ()
#5  0x0000000000504fcc in main ()


Hope I've been coherent enough, I'm a bit tired now. I'll come back later.

Anyway, thanks for your help ! :)
Attachments
ogre.log
(25.85 KiB) Downloaded 63 times
log.txt
(600 Bytes) Downloaded 62 times
eaoden
 
Posts: 7
Joined: 12 Nov 2014, 17:39

Re: Crash after the loading screen

Postby CryHam » 12 Nov 2014, 18:32

* Supported Shader Profiles: arbfp1 arbvp1 glsl
This is way too few. it's like nothing.
Surely won't start. No idea if your GPU doesn't have them (should have, looks new) or some driver issue (and it doesn't get detected).
This is what I got there:
18:30:12: * Supported Shader Profiles: arbfp1 arbvp1 fp20 fp30 fp40 glsl glsl100 glsl110 glsl120 gp4fp gp4gp gp4vp gpu_fp gpu_gp gpu_vp nvgp4 vp30 vp40
User avatar
CryHam
SR Moderator
 
Posts: 694
Joined: 25 Nov 2012, 08:40

Re: Crash after the loading screen

Postby Calinou » 12 Nov 2014, 18:52

You are starting Stunt Rally on the integrated graphics processor:

{l Code}: {l Select All Code}
17:41:30: GL_VERSION = 3.0 Mesa 10.3.1
17:41:30: GL_VENDOR = Intel Open Source Technology Center
17:41:30: GL_RENDERER = Mesa DRI Intel(R) Ivybridge Mobile


Using Optimus or something like that, run optirun stuntrally, which will force the game to start on the dedicated graphics card.
User avatar
Calinou
 
Posts: 161
Joined: 22 Jan 2010, 21:43
Location: France

Re: Crash after the loading screen

Postby eaoden » 12 Nov 2014, 22:34

Thank you for your answers.

CryHam, can the fact that StuntRally would be starting on the integrated processor explain that there are not enough supported shaders profiles ?

Calinou, I ran optirun stuntrally but it crashed. The output contains :
{l Code}: {l Select All Code}
Widget property 'ReadOnly' not found [Game.layout]
Widget property 'MultiLine' not found [Game.layout]
Widget property 'WordWrap' not found [Game.layout]


It's the same than when i just run stuntrally. Do you know how I can get these widgets ?

Again, thank you for your help.
eaoden
 
Posts: 7
Joined: 12 Nov 2014, 17:39

Re: Crash after the loading screen

Postby CryHam » 12 Nov 2014, 22:41

It could. There were similar issues when starting on integrated cards.
I'm not sure what was causing them or if anybody managed to start on those.
It will crash if there is no fp20 fp30 in shaders in log. We need those for most shaders.
No idea why also MyGui things appear but, well the shaders are needed for sure.
User avatar
CryHam
SR Moderator
 
Posts: 694
Joined: 25 Nov 2012, 08:40

Re: Crash with Integrated GPU, Mobile, Mesa

Postby CryHam » 14 Nov 2014, 13:55

That output doesn't have anything useful. Could be just warnings. And again MyGui isn't fault here.
Be sure you start SR on your GPU and not the integrated one.
You should then have Nvidia GEFORCE GT 635M or something like that in ogre.log, and not that Intel or Mobile.
If it crashes post ogre.log again.
User avatar
CryHam
SR Moderator
 
Posts: 694
Joined: 25 Nov 2012, 08:40

Re: Crash with Integrated GPU, Mobile, Mesa

Postby eaoden » 14 Nov 2014, 14:23

Ok, here it is
Attachments
ogre.log
(23.48 KiB) Downloaded 71 times
eaoden
 
Posts: 7
Joined: 12 Nov 2014, 17:39

Re: Crash with Integrated GPU, Mobile, Mesa

Postby CryHam » 14 Nov 2014, 14:50

Right. Is the same problem:
* Supported Shader Profiles: arbfp1 arbvp1 glsl
So, missing the ones we need. No idea.
But at least it shows other GPU there: Device Name: Gallium 0.4 on NVC1, GL_VENDOR = nouveau.
There isn't your GPU name anywhere there (GT 635M). Should be IMO, this looks like it's not detected (or supported?), IDK.
I'm gonna blame it on drivers, laptop and mobile GPU etc. I would try other drivers too, no idea if that'd change anything though.
Heh my 600th post.
Did you try other games using GL?
And did you try our binary release?
User avatar
CryHam
SR Moderator
 
Posts: 694
Joined: 25 Nov 2012, 08:40

Re: Crash with Integrated GPU, Mobile, Mesa

Postby eaoden » 14 Nov 2014, 17:41

Ok, I'll try other drivers.

No, I didn't try other games, I'm running Manjaro from one week or two.

I didn't try your binary release too, let's check this later. Thank you again for your help.
eaoden
 
Posts: 7
Joined: 12 Nov 2014, 17:39

Re: Crash with Integrated GPU, Mobile, Mesa

Postby eaoden » 16 Nov 2014, 12:56

Hello,

I downlaoded the NVIDIA .run file for the drivers, I put a chmod +x and ran it in sudo. Here is what I got :

ERROR: You appear to be running an X server; please exit X before
installing. For further details, please see the section INSTALLING
THE NVIDIA DRIVER in the README available on the Linux driver
download page at http://www.nvidia.com.

For the binaries, I downloaded it from the github project (git https://github.com/stuntrally/stuntrally.git && make). It still doesn't work.

Thank you for still helping me, that's awesome.
eaoden
 
Posts: 7
Joined: 12 Nov 2014, 17:39

Re: Crash with Integrated GPU, Mobile, Mesa

Postby Calinou » 16 Nov 2014, 17:30

eaoden {l Wrote}:Hello,

I downlaoded the NVIDIA .run file for the drivers, I put a chmod +x and ran it in sudo. Here is what I got :

ERROR: You appear to be running an X server; please exit X before
installing. For further details, please see the section INSTALLING
THE NVIDIA DRIVER in the README available on the Linux driver
download page at http://www.nvidia.com.

For the binaries, I downloaded it from the github project (git https://github.com/stuntrally/stuntrally.git && make). It still doesn't work.

Thank you for still helping me, that's awesome.


You do not use the .run file from nvidia.com. Use the package provided by your package manager. Please ask on your distribution's support forums or IRC channel.
User avatar
Calinou
 
Posts: 161
Joined: 22 Jan 2010, 21:43
Location: France

Re: Crash with Integrated GPU, Mobile, Mesa

Postby eaoden » 22 Nov 2014, 15:23

Hello,

I installed the nvidia driver (sudo mhwd -f -a pci nonfree 0300) but the game still crashes, even when I'm running it with optirun.

Here are my ogre.log and log.txt files.
Attachments
log.txt
(600 Bytes) Downloaded 65 times
ogre.log
(25.93 KiB) Downloaded 65 times
eaoden
 
Posts: 7
Joined: 12 Nov 2014, 17:39

Re: Crash with Integrated GPU, Mobile, Mesa

Postby CryHam » 22 Nov 2014, 20:51

OK. This is very good:
12:29:35: Device Name: GeForce GT 635M/PCIe/SSE2
12:29:35: * Supported Shader Profiles: arbfp1 arbvp1 fp20 fp30 fp40 glsl gp4fp gp4gp gp4vp gpu_fp gpu_gp gpu_vp nvgp4 vp30 vp40
so definitely should run.

But you're not starting the newest version:
Total tracks: 147, total time: 4:19 h:m,
this is previous, 2.4. Get our newest binaries with 2.5 and try those.

No idea what is crashing, completely nothing in logs.
Could be something like wrong data files or config?
User avatar
CryHam
SR Moderator
 
Posts: 694
Joined: 25 Nov 2012, 08:40

Re: Crash with Integrated GPU, Mobile, Mesa

Postby eaoden » 22 Nov 2014, 21:45

Thank you for your help.

I'll download Stuntrally again monday, when I'll have a good Internet connexion :P

I can also upload my data or config files.

Have a nice evening.
eaoden
 
Posts: 7
Joined: 12 Nov 2014, 17:39

Who is online

Users browsing this forum: No registered users and 1 guest