Game testing 2.5

Game testing 2.5

Postby CryHam » 23 Oct 2014, 15:36

Since we are not far from release, a new topic.
Testing master is most welcome.
Also if any translations need updating.
User avatar
CryHam
SR Moderator
 
Posts: 694
Joined: 25 Nov 2012, 08:40

Re: Game testing 2.5

Postby CryHam » 23 Oct 2014, 15:39

By dimproject:
Close button or hint for Track Filter window
TrackFilter1.jpg
User avatar
CryHam
SR Moderator
 
Posts: 694
Joined: 25 Nov 2012, 08:40

Re: Game testing 2.5

Postby CryHam » 23 Oct 2014, 15:41

Yeah IDK, this window and also in editor Pick window or Color windows are similar and
are closed the same way as they are opened (by clicking a small button or color).
Could be also closed by toggling Gui off and then on, I'm not a fan of X buttons to close but well maybe should have.
User avatar
CryHam
SR Moderator
 
Posts: 694
Joined: 25 Nov 2012, 08:40

Re: Game testing 2.5 ...

Postby krash » 24 Oct 2014, 12:43

Hello,

I have some trouble with the track editor (using self-compiled git master branch)

Debian Wheezy
Ogre 1.9
Open Source Radeon Driver


* While applying the Filter brush several times, the Terrain mesh
somehow got distorted (might be a heightmap problem?) (screenshot 1).

* Also, the current brush is never displayed (screenshot 2).


I have attached the map.

Cryham do you have any idea what could have caused this?

Thank you very much!
Attachments
For18-Run!.zip
(2.97 MiB) Downloaded 60 times
screenshot2.jpg
screenshot1.jpg
krash
 
Posts: 12
Joined: 24 Dec 2012, 01:11

Re: Game testing 2.5 ...

Postby CryHam » 24 Oct 2014, 12:54

Ugh. This is some serious sh!t.
IDK. Does it happen only with filter brush? Does it happen every time? (E.g. other brushes or other filter param value).
Do our 2.4 binaries have that too?
Looks like crazy big float values in brush height that went onto terrain. I had that during testing, but shouldn't normally happen.
User avatar
CryHam
SR Moderator
 
Posts: 694
Joined: 25 Nov 2012, 08:40

Re: Game testing 2.5 ...

Postby Wuzzy » 24 Oct 2014, 14:51

Comments about the filter window: The table becomes over-crowded when you make a checkmark into every box.
The fields “Name” and “Name (big)” should exclude each other, it should not be possible to select both at once. With this change, all possible configurations would fit into the main window.


Also, the field names should be a bit longer in the window, it does not work very well with the German translation.
The version field should show “0.1” to “2.5”, not “1” to “25”.
And maybe, if there’s enough space, it would be helpful if those numbers could be explained. The meaning of “banked - 5” and the like is probably not obvious to everyone. ;)

Things seem to become really slow when you drag the scrollbar with the mouse. Weird.

I hope I can report more test results later.
User avatar
Wuzzy
 
Posts: 484
Joined: 28 May 2012, 23:13

Re: Game testing 2.5 ...

Postby CryHam » 24 Oct 2014, 18:11

Right but, please focus on testing serious things not the freaking filter window that I just coded.
Seems like you don't know how long it takes and boring it is, to adjust the crappy distance for all things like those checks, etc. And have proper scaling.
User avatar
CryHam
SR Moderator
 
Posts: 694
Joined: 25 Nov 2012, 08:40

Re: Game testing 2.5 ...

Postby Wuzzy » 24 Oct 2014, 20:32

Look: I just want to help. You wanted testing, you got testing. This includes reporting small issues.

I know very well how annoying it is to get a GUI right. But weather you like it or not, it’s a task which needs to be done nonetheless. And because you posted the filter into this thread, I tested it, of course. And you asked me for testing Stunt Rally. Whatever, you are right: It is not really the most pressing thing.

OK, but I try to seek out for the larger bugs from now on, but I won’t stop reporting small bugs if I stumple upon then in the process.

The flicker bug (http://forum.freegamedev.net/viewtopic.php?f=78&t=5419) seems to make its debut:

Image
Except that it is not flickering now, but large black areas. :/

It seems that it appears / disappears under the same conditions as the old flicker bug. Reloading the track does not help here. :/


Oh, and messages appear twice in the chat sometimes, but you know that already.

I report back when I find more bugs.
User avatar
Wuzzy
 
Posts: 484
Joined: 28 May 2012, 23:13

Re: Game testing 2.5 ...

Postby CryHam » 24 Oct 2014, 20:56

Ah crap. Will we ever have terrain without being black or having other issues.
I'm clueless with it. Could be sth in shader since it is big and have many vars in it but IDK really.
PS. Yeah I understand.
User avatar
CryHam
SR Moderator
 
Posts: 694
Joined: 25 Nov 2012, 08:40

Re: Game testing 2.5 ...

Postby Wuzzy » 25 Oct 2014, 15:12

The new track Wnt17-FrozenGarden does not have all objects which are neccessary for it. The signs are missing completely.
The ring objects are there, but the textures are missing. Same is true for the metal “frameworks”.

I guess you either forgot it or it is still on TODO.


EDIT:
Due to the recent track name change, some challenges and championships must be updated, because they still use the old track names:

  • Challenge “Really Dangerous” (Vlc7-Radioactive: update name)
  • Championship “Dark Chase” (Vlc7-Radioactive: update name)
  • Championship “Volcanic” (Vlc7-Radioactive: remove this from the championship, since it is not volcanic)

EDIT 2:
I saw the options “Auto Rear gear” and “Rear throttle inverse” in the single race setup. I don’t really understand where’s the difference between both. :think:
User avatar
Wuzzy
 
Posts: 484
Joined: 28 May 2012, 23:13

Re: Game testing 2.5 ...

Postby Calinou » 25 Oct 2014, 17:48

Wuzzy {l Wrote}:I saw the options “Auto Rear gear” and “Rear throttle inverse” in the single race setup. I don’t really understand where’s the difference between both. :think:


One lets you go from 1 (or N) to R by just braking, the other lets you go backwards by braking and go forwards by accelerating.
User avatar
Calinou
 
Posts: 161
Joined: 22 Jan 2010, 21:43
Location: France

Re: Game testing 2.5 ...

Postby Wuzzy » 25 Oct 2014, 18:54

OK, thanks.

I am currently experimenting with challenges right now. I also stumpled upon the “prizes” attribute in the XML file and I noticed that it does not work as expected.

According to the comment, the prizes attibute is supposed to limit the possible rewards you can get (gold, silver and bronze, gold and silver or only gold).
It turns out that it does not work. Currently, no challenge uses this function yet, so I wrote two test challenges.

Insert this code into challenges.xml to try to reproduce it:
{l Code}: {l Select All Code}
   <challenge name="Prizes Test 1" ver="1" difficulty="1" type="7"
         descr="Test the prizes element (gold only).">
      <car names="S8" />
      <pass avgPoints="10" prizes="0" />
      <tracks>
         <t name="TestC4-ow" laps="1" passPoints="5"/>
      </tracks>
   </challenge>

   <challenge name="Prizes Test 2" ver="1" difficulty="1" type="7"
         descr="Test the prizes element (gold and silver).">
      <car names="S8" />
      <pass avgPoints="10" prizes="1" />
      <tracks>
         <t name="TestC4-ow" laps="1" passPoints="5"/>
      </tracks>
   </challenge>


This tests the non-default cases: Gold and silver, gold only. I set the passing score for both challenges to 10.

After testing this, I had the following results:

Prizes Test 1:
I finished with over 10 points, but I only got bronze. Also, the passing score shown on the final dialog was 8.0, not 10 as specified in the XML! At least the color was right, lol.
I expect to win gold and that the passing score for the whole thing is of course 10.

Prizes Test 2:
I finished with over 10 points, but I only got silver. The passing scores were 9.0 for gold and 8.0 for silver.
I should have won gold and the passing scores should have been 10 for gold and 9 for silver.



EDIT:
When playing a replay, the shown damage percentage does not update correctly. I have made simple trip into an acid lake, recorded it, replayed it. The replay showed 0% damage all the time.

EDIT 2:
The challenge definition of the challenge “Stunt Sway” has a typo: There is a car “FM” in the definition, but this car does not exist. I bet you meant FN. ;)
User avatar
Wuzzy
 
Posts: 484
Joined: 28 May 2012, 23:13

Re: Game testing 2.5 ...

Postby Calinou » 26 Oct 2014, 09:30

Wuzzy {l Wrote}:There is a car “FM” in the definition, but this car does not exist. I bet you meant FN. ;)


In 2.3/2.4, FM was changed for FN (new model).
User avatar
Calinou
 
Posts: 161
Joined: 22 Jan 2010, 21:43
Location: France

Re: Game testing 2.5 ...

Postby rubberduck » 26 Oct 2014, 09:42

another graphics issue i forgot

some strange black dots appearing on terrain (moving and only close to the new solid ice fluid)
next_graphics_issue.jpg
working on LaundredSheep, a 3D platformer game
https://forum.freegamedev.net/viewtopic.php?f=22&t=7531
User avatar
rubberduck
 
Posts: 614
Joined: 23 Apr 2013, 18:31
Location: sitting with tux in a bathtub

Re: Game testing 2.5 ...

Postby Wuzzy » 26 Oct 2014, 12:29

@rubberduck: This looks like the old flickering bug I reported.

EDIT:
Okay, the replay system seems to be a bit buggy, especially the HUD. When viewing a replay, a lot of HUD elements don’t seem to be updated. The track progress percentage seems to not change at all, the damage counter behaves weirdly (see challenges and championships thread) and the checkpoint beam always stays at the first checkpoint. Also, the boost counter is not updated either.

EDIT 2:
You probably already know that, but just for completeness’ sake: A hard collision with an ice surface causes no damage.

EDIT 3:
Spc1-Minerals has an extreme case of Z-fighing at the crossings.
User avatar
Wuzzy
 
Posts: 484
Joined: 28 May 2012, 23:13

Re: Game testing 2.5 ...

Postby dimproject » 29 Oct 2014, 16:54

Some strings shows on English only.
I marked them.
GameBoost.jpg
dimproject
 
Posts: 212
Joined: 18 Jul 2013, 13:51

Re: Game testing 2.5 ...

Postby Wuzzy » 29 Oct 2014, 21:00

I had this after driving Crater Survival:
Image

Look closely. It seems some text has been unfortunately cut off, above “Preis: Gold”. I used the resultion 1680×1050.
User avatar
Wuzzy
 
Posts: 484
Joined: 28 May 2012, 23:13

Re: Game testing 2.5 ...

Postby CryHam » 02 Nov 2014, 10:06

Ugh. Yeah that was the line with "Challenge: name". Which happened bcoz Bestanden didn't fit previous line.
Hey, isn't Gluckwunch good luck, while it had to be congratulations?
And I've seen now it's now not Du hast, but Sie haben, which ok is nice, but it cuts the line, doesn't fit in 1680x1050.
I'm making area bigger.
User avatar
CryHam
SR Moderator
 
Posts: 694
Joined: 25 Nov 2012, 08:40

Re: Game testing 2.5 ...

Postby Wuzzy » 02 Nov 2014, 20:11

“Glückwunsch!” or “Herzlichen Glückwunsch!” means “Congratulations!”.
“Good luck!” translates to (among others) “Viel Glück!” (literally: “Much luck!”, it’s an idiom like in English).

http://www.dict.cc/?s=good+luck
http://www.dict.cc/?s=Congratulations%21
http://www.dict.cc/?s=Gl%C3%BCckwunsch%21

Seriously, CryHam, you should learn more German before you attempt to translate. :p
User avatar
Wuzzy
 
Posts: 484
Joined: 28 May 2012, 23:13

Re: Game testing 2.5 ...

Postby CryHam » 02 Nov 2014, 20:33

Ah heh okay.
Btw. Update list on multiplayer tab goes over button. Could just use one string not 2 with / (only for update not also fill).
User avatar
CryHam
SR Moderator
 
Posts: 694
Joined: 25 Nov 2012, 08:40

Who is online

Users browsing this forum: No registered users and 1 guest