Xubuntu 15.10 CMake error...

Xubuntu 15.10 CMake error...

Postby Dolus_Astus » 18 Nov 2015, 02:20

logan@logan:~/Documents/ValyriaTear-master$ cmake . && make
-- The C compiler identification is GNU 5.2.1
-- The CXX compiler identification is GNU 5.2.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found SDL2: /usr/include/SDL2 (found version "2.0.2")
-- Found SDL2_ttf: /usr/include/SDL2 (found version "2.0.12")
-- Found SDL2_image: /usr/include/SDL2 (found version "2.0.0")
-- Found OpenGL: /usr/lib/x86_64-linux-gnu/libGL.so
-- Found GLEW: /usr/lib/x86_64-linux-gnu/libGLEW.so
-- Found OpenAL: /usr/lib/x86_64-linux-gnu/libopenal.so
-- Found VORBISFILE: optimized;/usr/lib/x86_64-linux-gnu/libvorbisfile.so;debug;/usr/lib/x86_64-linux-gnu/libvorbisfile.so
-- Found Lua51: /usr/lib/x86_64-linux-gnu/liblua5.1.so;/usr/lib/x86_64-linux-gnu/libm.so (found version "5.1.5")
-- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.8")
-- Found PNG: /usr/lib/x86_64-linux-gnu/libpng.so (found version "1.2.51")
-- Found Gettext: /usr/bin/msgmerge (found version "0.19.4")
-- Boost version: 1.58.0
-- Build type: Release
-- l10n support enabled
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Using included luabind files
CMake Error: File /home/logan/Documents/ValyriaTear-master/src/luabind/build_information.hpp.cmake_in does not exist.
CMake Error at src/CMakeLists.txt:126 (CONFIGURE_FILE):
configure_file Problem configuring file


-- Configured luabind information file...
-- Configuring incomplete, errors occurred!
See also "/home/logan/Documents/ValyriaTear-master/CMakeFiles/CMakeOutput.log".
Attachments
CMakeOutput.log
(50.67 KiB) Downloaded 113 times
Dolus_Astus
 
Posts: 4
Joined: 17 Nov 2015, 23:40

Re: Xubuntu 15.10 CMake error...

Postby Akien » 18 Nov 2015, 21:18

If you want to compile ValyriaTear from the GitHub repo, it won't work out of the box using the generated zipfile or tarball, as it does not include the necessary luabind submodule in src/luabind.

So you would need to clone the repo instead:
$ git clone https://github.com/ValyriaTear/ValyriaTear
$ git submodule update --init --remote

Alternatively, you can download a snapshot of https://github.com/ValyriaTear/luabind and put its contents in src/luabind.
User avatar
Akien
 
Posts: 730
Joined: 22 Feb 2014, 13:14

Re: Xubuntu 15.10 CMake error...

Postby Dolus_Astus » 18 Nov 2015, 23:39

Thanks for the quick reply! Now it compiles fine
Dolus_Astus
 
Posts: 4
Joined: 17 Nov 2015, 23:40

Re: Xubuntu 15.10 CMake error...

Postby Bertram » 23 Nov 2015, 17:17

Thanks Akien,

I've also added this issue:
https://github.com/ValyriaTear/ValyriaTear/issues/504

I'll fix that asap.
User avatar
Bertram
VT Moderator
 
Posts: 1635
Joined: 09 Nov 2012, 12:26

Re: Xubuntu 15.10 CMake error...

Postby Bertram » 25 Nov 2015, 19:02

For info, the Travis build (which had the same issue) is also now fixed.

Cheers,
User avatar
Bertram
VT Moderator
 
Posts: 1635
Joined: 09 Nov 2012, 12:26

Who is online

Users browsing this forum: No registered users and 1 guest