[solved] Arch Linux build fail, probably only half-related

[solved] Arch Linux build fail, probably only half-related

Postby qubodup » 02 Jan 2014, 00:20

Hi, I can't compile Valyria Tear and I'm overwhelmed by the output http://codepad.org/xQGqCjXr .

As far as I understand, luabind is included? I just tried to compile luabind from https://aur.archlinux.org/packages/luabind/ and get an error (posted at link). Boost might be the issue ( https://bbs.archlinux.org/viewtopic.php?id=166725 is linked in the comments and the thread replies suggest it).

I don't really understand what's going on but have reported the issue at least in Arch's issue tracker:
https://bugs.archlinux.org/task/38347

Here's all the info about my system just in case
{l Code}: {l Select All Code}
Distro      Linux qbox 3.12.6-1-ARCH #1 SMP PREEMPT Fri Dec 20 19:39:00 CET 2013 x86_64 GNU/Linux
CPU         model name : AMD Phenom(tm) 9550 Quad-Core Processor
Video         01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS780 [Radeon HD 3200] (prog-if 00 [VGA controller])
Video memory   [256M]
RAM         Mem: 3.6G 2.1G 1.5G 24M 50M 495M
GCC         gcc (GCC) 4.8.2 20131219 (prerelease)
VGA driver  OpenGL vendor string: X.Org
Video driver packages:
local/xf86-video-ati 1:7.2.0-1 (xorg-drivers xorg)
local/xf86-video-vesa 2.3.2-3 (xorg-drivers xorg)
$ pacman -Q lua zlib libpng libvorbis openal mesa glu sdl sdl_ttf sdl_image
lua 5.2.3-1
zlib 1.2.8-3
libpng 1.6.7-1
libvorbis 1.3.3-1
openal 1.15.1-1
mesa 10.0.1-1
glu 9.0.0-2
sdl 1.2.15-5
sdl_ttf 2.0.11-2
sdl_image 1.2.12-3
User avatar
qubodup
Global Moderator
 
Posts: 1671
Joined: 08 Nov 2009, 22:52
Location: Berlin, Germany

Re: Arch Linux build fail, probably only half-related

Postby Bertram » 03 Jan 2014, 23:15

Hi qubodup, :)

And happy new year! :cool:

By looking at the compile log, in line 3, there is the following error:
{l Code}: {l Select All Code}
[...] undefined reference to `lua_getglobal'

Which is leading me to think the lua (not the luabind) version between the compiling process and the linking process is not the same.
It can be either 5.1 or 5.2 but you shouldn't mix them.

As far as I understand, luabind is included?

Yes, because there are (or were) discrepancies between the distributions, so I kept the included luabind version, and added several improvements and fixes there, but you can still use the system luabind version, eg here:
viewtopic.php?f=76&t=4271

Even if, to me, it's not related to your current problem.

All in all, you should try to compile Valyria Tear using the same lua cmake parameters than there:
https://aur.archlinux.org/packages/va/v ... r/PKGBUILD

Explicitely:
{l Code}: {l Select All Code}
cmake -DLUA_LIBRARIES=/usr/lib/liblua5.1.so -DLUA_INCLUDE_DIR=/usr/include/lua5.1/ .


(Don't forget to recompile everything.)

I hope it will help you.

Best regards,
User avatar
Bertram
VT Moderator
 
Posts: 1635
Joined: 09 Nov 2012, 12:26

Re: Arch Linux build fail, probably only half-related

Postby qubodup » 04 Jan 2014, 04:22

Thanks, I hope I won't be posting disoriented reports each time the lua version increments...

I was able to compile using your line! This allowed me to test the gamepads and record this incredibly 'useful' video of me doing so http://youtu.be/3ot0GUNlnNo .

FYI: I have both lua and lua51 installed. Below all files except docs/licensefiles/manpages:
{l Code}: {l Select All Code}
lua /usr/include/lauxlib.h
lua /usr/include/lua.h
lua /usr/include/lua.hpp
lua /usr/include/luaconf.h
lua /usr/include/lualib.h
lua /usr/lib/liblua.so
lua /usr/lib/liblua.so.5.2
lua /usr/lib/liblua.so.5.2.3
lua /usr/lib/pkgconfig/lua.pc
lua51 /usr/bin/lua5.1
lua51 /usr/bin/luac5.1
lua51 /usr/include/lua5.1/
lua51 /usr/include/lua5.1/lauxlib.h
lua51 /usr/include/lua5.1/lua.h
lua51 /usr/include/lua5.1/lua.hpp
lua51 /usr/include/lua5.1/luaconf.h
lua51 /usr/include/lua5.1/lualib.h
lua51 /usr/lib/liblua.so.5.1
lua51 /usr/lib/liblua.so.5.1.5
lua51 /usr/lib/liblua5.1.so
lua51 /usr/lib/liblua5.1.so.5.1
lua51 /usr/lib/liblua5.1.so.5.1.5
lua51 /usr/lib/pkgconfig/lua5.1.pc
User avatar
qubodup
Global Moderator
 
Posts: 1671
Joined: 08 Nov 2009, 22:52
Location: Berlin, Germany

Re: [solved] Arch Linux build fail, probably only half-relat

Postby Bertram » 06 Jan 2014, 11:23

Hi qubodup, :)

I really liked the "raaaahhh ffff... damn.... ok" part of the video and I think you found a bug there. (I'll deal with this soon.)

I'm rather happy that joypads I've never heard of are actually working fine, at least overall. :)

To answer some questions:
Yes, the game is taking only the first joypad/joystick in account as a result of using a basic SDL implementation in the joystick selection, and yes it is taking only the first Hat/D-Pad in account.
Also, once you've unplugged your joystick, it's often dead to get it back to work without restarting the game. You'll have to wait for the migration to SDL 2.x before something better there.

Regards,
User avatar
Bertram
VT Moderator
 
Posts: 1635
Joined: 09 Nov 2012, 12:26

Who is online

Users browsing this forum: No registered users and 1 guest