Supertux 6.0 appimage won't start

Supertux 6.0 appimage won't start

Postby Random Paradox » 19 Jun 2019, 16:10

When i try to start up supertux, I get this error:
[WARNING] /home/travis/build/SuperTux/supertux/src/video/video_system.cpp:52 Error creating GLVideoSystem-330core, using GLVideoSystem-20 fallback: Couldn't set video mode 1920x1135: Couldn't find matching GLX visual
Does anyone why this happens and how to fix it?
Completer of the Ling Ling Workout.
Random Paradox
 
Posts: 36
Joined: 07 Jan 2019, 02:54
Location: The earth (duh)

Re: Supertux 6.0 appimage won't start

Postby fluffrabbit » 19 Jun 2019, 19:04

My naive assumption would be that your system lacks GL 3.3 hardware drivers, so you could start by trying the Mesa software driver:

{l Code}: {l Select All Code}
export LIBGL_ALWAYS_SOFTWARE=1
./supertux


As a developer who does a lot of OpenGL stuff, I would really like to know if this solves the problem for you. If not, my only advice is that people have been experiencing similar GL issues with recent releases of SuperTux (another thread here where where I suggested the same thing, and in which an idiot suggested that it "doesn't seem logical" because other apps would break, incorrectly asserting or implying that every piece of software requests the same GL version), so maybe try an older version of SuperTux if all else fails.

EDIT: It does say that it's taking a stab at GL 2 fallback mode, so perhaps there is an actual bug in an actual piece of software here, not sure.
fluffrabbit
 
Posts: 570
Joined: 11 Apr 2019, 11:17

Re: Supertux 6.0 appimage won't start

Postby Random Paradox » 20 Jun 2019, 01:45

Believe it or not, I already tried that. Still gave me that error.
Completer of the Ling Ling Workout.
Random Paradox
 
Posts: 36
Joined: 07 Jan 2019, 02:54
Location: The earth (duh)

Re: Supertux 6.0 appimage won't start

Postby fluffrabbit » 20 Jun 2019, 04:33

Random Paradox {l Wrote}:Believe it or not, I already tried that. Still gave me that error.

Then it sounds to me like SuperTux itself is broken. When initializing OpenGL, one can tell their initializer to go "hardware only", which will override any flags to the contrary. This combined with other issues can make a game unplayable. The SuperTux developer does lurk around here, so let's see what he has to say about it.
fluffrabbit
 
Posts: 570
Joined: 11 Apr 2019, 11:17

Re: Supertux 6.0 appimage won't start

Postby Random Paradox » 13 Jul 2019, 03:04

Alright, as it turns out, all I had to do was update Kubuntu.
Completer of the Ling Ling Workout.
Random Paradox
 
Posts: 36
Joined: 07 Jan 2019, 02:54
Location: The earth (duh)

Re: Supertux 6.0 appimage won't start

Postby gwater » 18 Jan 2020, 00:48

In case this helps someone, I saw this error when launching a current ST build from source,(1/2020). I'm on an Ubuntu 16.xLTS virtual box. I did " export LIBGL_ALWAYS_SOFTWARE=1" and launched with ./supertux2 --renderer sdl. The error cleared for me after these moves.
gwater
 
Posts: 6
Joined: 28 Dec 2019, 16:46

Who is online

Users browsing this forum: No registered users and 1 guest