build failure with ogre 1.8 <SOLVED>

build failure with ogre 1.8 <SOLVED>

Postby shirish » 19 Aug 2013, 10:05

Hi all,
I am unable to install ogre 1.7 but was able to install ogre 1.8. I tried to build the game with it but failed.
{l Code}: {l Select All Code}
/games/lipsofsuna-code$ ./waf configure
Setting top to                           : /data/shirish/Games/lipsofsuna-code
Setting out to                           : /data/shirish/Games/lipsofsuna-code/.build
Checking for 'gcc' (c compiler)          : /usr/local/bin/gcc
Checking for 'g++' (c++ compiler)        : /usr/local/bin/g++
Checking for header dlfcn.h              : yes
Checking for header fcntl.h              : yes
Checking for header inotifytools/inotify.h : not found
Checking for header inttypes.h             : yes
Checking for header poll.h                 : yes
Checking for header stdint.h               : yes
Checking for header sys/inotify.h          : yes
Checking for header sys/mman.h             : yes
Checking for header sys/stat.h             : yes
Checking for header sys/time.h             : yes
Checking for header sys/wait.h             : yes
Checking for header time.h                 : yes
Checking for header unistd.h               : yes
Checking for header windows.h              : not found
Checking for header iconv.h                : yes
Checking for function fork                 : yes
Checking for function usleep               : yes
Checking for library dl                    : yes
Checking for library m                     : yes
Checking for library pthread               : yes
Checking for library iconv                 : not found
Checking for package zlib                  : pkg-config zlib
Checking for package sqlite                : pkg-config sqlite3
Checking for package bullet                : pkg-config bullet
Checking for package enet                  : pkg-config libenet
Checking for package lua                   : pkg-config lua5.1
Checking for package FreeImage             : library freeimage
Checking for package OGRE                  : pkg-config OGRE
Checking for OGRE plugindir                : pkg-config /usr/lib/x86_64-linux-gnu/OGRE-1.8.0
Checking for package OGRE-Terrain          : pkg-config OGRE-Terrain
Checking for package OIS                   : pkg-config OIS
Checking for package Xlib                  : library X11
Checking for package openal                : pkg-config openal
Checking for package ogg                   : pkg-config ogg
Checking for package vorbisfile            : pkg-config vorbisfile
Checking for package flac                  : pkg-config flac
Checking for package curl                  : pkg-config libcurl

Configured with:
   relative paths
   graphics support
   sound support
   master server connectivity
   image loading with FreeImage
   Ogre plugin directory: /usr/lib/x86_64-linux-gnu/OGRE-1.8.0

Build command: ./waf
Install command: ./waf install

'configure' finished successfully (4.997s)

First of all I'm a bit concerned about not being able to find library iconv , which library is this that the game is looking for ? The other two *.h files are probably something to do with MS-Windows, right ?

Went further to attempt to get a build happening

Any ideas why the build failed (apart from the missing iconv library ? )

Looking forward to understanding a bit.
Last edited by shirish on 19 Aug 2013, 13:20, edited 1 time in total.
Posts: 166
Joined: 17 Jan 2011, 15:06

Re: build failure with ogre 1.8

Postby amuzen » 19 Aug 2013, 11:57

User avatar
LoS Moderator
Posts: 327
Joined: 05 Dec 2009, 02:49

Re: build failure with ogre 1.8

Postby shirish » 19 Aug 2013, 12:57

hmm... on my system there is no /usr/lib/pkgconfig/OGRE.pc :-

{l Code}: {l Select All Code}
$ cd /usr/lib/pkgconfig/
/usr/lib/pkgconfig$ ls
dbus-python.pc  libmodplug.pc  mad.pc  pm-utils.pc  xorg-wacom.pc  zzipmmapped.pc gnome-js-common.pc  libquvi-scripts.pc  nautilus-sendto.pc  pygtksourceview-2.0.pc  zzipfseeko.pc  zzipwrap.pc gtranslator.pc  libudev.pc  notify-python.pc valgrind.pc  zziplib.pc zzip-zlib-config.pc

so please advise should I do :-
{l Code}: {l Select All Code}
LDFLAGS=-lboost_system ./waf configure

Update :- on a hunch did the one mentioned above, did a ./waf clean :-
{l Code}: {l Select All Code}
~/games/lipsofsuna-code$ ./waf clean
'clean' finished successfully (0.388s)

and then tried to build it again

As can be seen it was a success.
Posts: 166
Joined: 17 Jan 2011, 15:06

Who is online

Users browsing this forum: No registered users and 1 guest