A couple of errors

A couple of errors

Postby TheTrueDragonZ » 11 Oct 2015, 20:20

I followed the ubuntu compile instructions, yet I have found several errors.

1.

Command : sudo cmake -DCEGUI_HAS_FREETYPE=ON -DFREETYPE_H_PATH_ft2build=/usr/include/freetype2/ -DFREETYPE_H_PATH_ftconfig=/usr/include/freetype2/ -DFREETYPE_LIB=/usr/lib/i386-linux-gnu/libfreetype.so .

Output: -- Looking for OGRE...
-- Found Ogre Ghadamon (1.9.0)
-- Found OGRE: optimized;/usr/lib/i386-linux-gnu/libOgreMain.so;debug;/usr/lib/i386-linux-gnu/libOgreMain.so
-- Looking for OGRE_Paging...
-- Found OGRE_Paging: optimized;/usr/lib/i386-linux-gnu/libOgrePaging.so;debug;/usr/lib/i386-linux-gnu/libOgrePaging.so
-- Looking for OGRE_Terrain...
-- Found OGRE_Terrain: optimized;/usr/lib/i386-linux-gnu/libOgreTerrain.so;debug;/usr/lib/i386-linux-gnu/libOgreTerrain.so
-- Looking for OGRE_Property...
-- Found OGRE_Property: optimized;/usr/lib/i386-linux-gnu/libOgreProperty.so;debug;/usr/lib/i386-linux-gnu/libOgreProperty.so
-- Looking for OGRE_RTShaderSystem...
-- Found OGRE_RTShaderSystem: optimized;/usr/lib/i386-linux-gnu/libOgreRTShaderSystem.so;debug;/usr/lib/i386-linux-gnu/libOgreRTShaderSystem.so
-- Looking for OGRE_Volume...
-- Found OGRE_Volume: optimized;/usr/lib/i386-linux-gnu/libOgreVolume.so;debug;/usr/lib/i386-linux-gnu/libOgreVolume.so
-- Looking for OGRE_Overlay...
-- Found OGRE_Overlay: optimized;/usr/lib/i386-linux-gnu/libOgreOverlay.so;debug;/usr/lib/i386-linux-gnu/libOgreOverlay.so
-- Looking for CEGUI...
CMake Error at cmake/modules/FindCEGUI.cmake:453 (file):
file Internal CMake error when trying to open file:
/usr/local/cegui-0.8.3/cegui/include/Version.h for reading.
Call Stack (most recent call first):
CMakeLists.txt:411 (find_package)


CMake Error at cmake/modules/FindCEGUI.cmake:464 (message):
Can't found CEGUI version !
Call Stack (most recent call first):
CMakeLists.txt:411 (find_package)


-- Found CEGUI: /usr/local/cegui-0.8.3/lib/libCEGUIBase-0.so
-- Looking for CEGUI_FalagardWRBase...
-- Could not locate CEGUI_FalagardWRBase
-- Looking for CEGUI_Direct3D9Renderer...
-- Could not locate CEGUI_Direct3D9Renderer
-- Looking for CEGUI_Direct3D10Renderer...
-- Could not locate CEGUI_Direct3D10Renderer
-- Looking for CEGUI_Direct3D11Renderer...
-- Could not locate CEGUI_Direct3D11Renderer
-- Looking for CEGUI_DirectFBRenderer...
-- Could not locate CEGUI_DirectFBRenderer
-- Looking for CEGUI_IrrlichtRenderer...
-- Could not locate CEGUI_IrrlichtRenderer
-- Looking for CEGUI_NullRenderer...
-- Could not locate CEGUI_NullRenderer
-- Looking for CEGUI_OgreRenderer...
-- Could not locate CEGUI_OgreRenderer
-- Looking for CEGUI_OpenGLRenderer...
-- Could not locate CEGUI_OpenGLRenderer
-- Looking for CEGUI_CoronaImageCodec...
-- Could not locate CEGUI_CoronaImageCodec
-- Looking for CEGUI_DevILImageCodec...
-- Could not locate CEGUI_DevILImageCodec
-- Looking for CEGUI_FreeImageImageCodec...
-- Could not locate CEGUI_FreeImageImageCodec
-- Looking for CEGUI_SILLYImageCodec...
-- Could not locate CEGUI_SILLYImageCodec
-- Looking for CEGUI_STBImageCodec...
-- Could not locate CEGUI_STBImageCodec
-- Looking for CEGUI_TGAImageCodec...
-- Could not locate CEGUI_TGAImageCodec
-- Looking for CEGUI_ExpatParser...
-- Could not locate CEGUI_ExpatParser
-- Looking for CEGUI_LibxmlParser...
-- Could not locate CEGUI_LibxmlParser
-- Looking for CEGUI_RapidXMLParser...
-- Could not locate CEGUI_RapidXMLParser
-- Looking for CEGUI_TinyXMLParser...
-- Could not locate CEGUI_TinyXMLParser
-- Looking for CEGUI_XercesParser...
-- Could not locate CEGUI_XercesParser
-- Looking for CEGUI_LuaScriptModule...
-- Could not locate CEGUI_LuaScriptModule
-- Looking for CEGUI_toluapp...
-- Could not locate CEGUI_toluapp
-- Found SFML 2.1 in /usr/include
CMake Error at CMakeLists.txt:419 (message):
CEGUI version >= 0.8.0 required


-- Configuring incomplete, errors occurred!
See also "/home/thetruegamer/opendungeons-0.6.0/CMakeFiles/CMakeOutput.log".
See also "/home/thetruegamer/opendungeons-0.6.0/CMakeFiles/CMakeError.log".

This error I got while running this command to:

cmake -DCEGUI_LIBRARY_REL=/usr/local/cegui-0.8.3/lib/libCEGUIBase-0.so -DCEGUI_OGRE_LIBRARY_REL=/usr/local/cegui-0.8.3/lib/libCEGUIOgreRenderer-0.so -DCEGUI_INCLUDE_DIR=/usr/local/cegui-0.8.3/cegui/include/ -DCMAKE_CXX_FLAGS=-std=gnu++11 .

If you could help me with these errors, I would be very happy. :)
TheTrueDragonZ
 
Posts: 1
Joined: 11 Oct 2015, 20:13

Re: A couple of errors

Postby Danimal » 13 Oct 2015, 12:38

Hi, ill pass it to the code guys.
User avatar
Danimal
OD Moderator
 
Posts: 1327
Joined: 23 Nov 2010, 13:50

Re: A couple of errors

Postby Akien » 13 Oct 2015, 16:22

The relevant issue is:
{l Code}: {l Select All Code}
CMake Error at cmake/modules/FindCEGUI.cmake:453 (file):
file Internal CMake error when trying to open file:
/usr/local/cegui-0.8.3/cegui/include/Version.h for reading.


If the file exists, could you give the output of:
{l Code}: {l Select All Code}
file /usr/local/cegui-0.8.3/cegui/include/Version.h

{l Code}: {l Select All Code}
ls -l /usr/local/cegui-0.8.3/cegui/include/Version.h

{l Code}: {l Select All Code}
cat /usr/local/cegui-0.8.3/cegui/include/Version.h


What version of CMake are you using? Also how did you install CEGUI? The path seems a bit unusual to me, with CEGUI 0.8.3 I think it would be something like /usr/local/include/cegui-0/CEGUI. Did you copy the source code manually into /usr/local? If so you should probably install it system-wide with "make install" instead.
Godot Engine project manager and maintainer.
Occasional FOSS gamedev: Lugaru, OpenDungeons, Jetpaca, Minilens.
User avatar
Akien
 
Posts: 738
Joined: 22 Feb 2014, 13:14

Who is online

Users browsing this forum: No registered users and 1 guest