BAD BUG: wrong teleporter and other blocks ID

BAD BUG: wrong teleporter and other blocks ID

Postby acme_pjz » 25 May 2012, 17:31

I have found a bad bug: create a new map, add two teleporters, save the map and exit, then reload the map, add a new teleporter, then open your level using text editor, you'll find that there are duplicated IDs :| If you repeat the process above the level will get broken eventually, i.e. can't set teleporter target anymore :(
Some of my open source games on GitHub
User avatar
acme_pjz
 
Posts: 585
Joined: 10 Dec 2009, 15:32
Location: PeeKing, China

Re: BAD BUG: wrong teleporter and other blocks ID

Postby acme_pjz » 25 May 2012, 17:51

For example, there is a level which has the bad bug... although I have edited the block ID manually but the level is still broken, i.e. can't set teleporter target or the target is completely wrong, etc.
Attachments
map02.zip
(1.63 KiB) Downloaded 69 times
Some of my open source games on GitHub
User avatar
acme_pjz
 
Posts: 585
Joined: 10 Dec 2009, 15:32
Location: PeeKing, China

Re: BAD BUG: wrong teleporter and other blocks ID

Postby Edward_Lii » 27 May 2012, 15:36

Hello acme_pjz,

I've found the source of the problem, it had to do with calculating the currentId in the postLoad function.
What went wrong was that in case of a teleporter it would return if it had no destination, instead of break. ;)
From,
Edward_Lii
User avatar
Edward_Lii
MnMS Moderator
 
Posts: 777
Joined: 20 Dec 2010, 16:46

Re: BAD BUG: wrong teleporter and other blocks ID

Postby acme_pjz » 27 May 2012, 17:03

Hi Edward_Lii,

Yes it's fixed :)
Some of my open source games on GitHub
User avatar
acme_pjz
 
Posts: 585
Joined: 10 Dec 2009, 15:32
Location: PeeKing, China

Who is online

Users browsing this forum: No registered users and 1 guest

cron