BUG: addons don't install properly

BUG: addons don't install properly

Postby ctdabomb » 16 Apr 2012, 16:17

I installed two addons and a theme from the addon manager, but the levels didn't show up until I had restarted the game. the theme showed up in the options right away, but it doesn't work :(
Some people are like slinkies... not really good for anything, but you still can't help smiling when you shove them down the stairs.
ctdabomb
SuperTux Moderator
 
Posts: 1073
Joined: 13 Dec 2011, 21:21
Location: halfway there

Re: BUG: addons don't install properly

Postby Edward_Lii » 16 Apr 2012, 18:43

Hello ctdabomb,

I assume you are using the latest svn, right?
ctdabomb {l Wrote}:I installed two addons and a theme from the addon manager, but the levels didn't show up until I had restarted the game.

Strange that they didn't show up, I'll look into it.
Perhaps it has something to do with the (recently) added LevelPackManager.

ctdabomb {l Wrote}:the theme showed up in the options right away, but it doesn't work :(

What is the error you see/get and what is the command line output?

Thanks for reporting these issues. :)
From,
Edward_Lii
User avatar
Edward_Lii
MnMS Moderator
 
Posts: 770
Joined: 20 Dec 2010, 16:46

Re: BUG: addons don't install properly

Postby ctdabomb » 16 Apr 2012, 19:43

Edward_Lii {l Wrote}:Hello ctdabomb,

I assume you are using the latest svn, right?

yes
Edward_Lii {l Wrote}:What is the error you see/get and what is the command line output?

:( didn't try, should I? i have a notorious past of not getting that to work.
Some people are like slinkies... not really good for anything, but you still can't help smiling when you shove them down the stairs.
ctdabomb
SuperTux Moderator
 
Posts: 1073
Joined: 13 Dec 2011, 21:21
Location: halfway there

Re: BUG: addons don't install properly

Postby Edward_Lii » 16 Apr 2012, 19:54

Hello ctdabomb,

ctdabomb {l Wrote}::( didn't try, should I? i have a notorious past of not getting that to work.

It could make debugging slightly easier. ;)

Don't worry it's not that hard, you run it the same way as you do normally, but instead of using a gui (clicking the binary) you run the binary from the command line.
Start a terminal and go to the directory meandmyshadow is located and then run:
{l Code}: {l Select All Code}
./meandmyshadow


If you have any questions left feel free to ask. ;)
From,
Edward_Lii
User avatar
Edward_Lii
MnMS Moderator
 
Posts: 770
Joined: 20 Dec 2010, 16:46

Re: BUG: addons don't install properly

Postby ctdabomb » 16 Apr 2012, 20:06

here is the stuff
{l Code}: {l Select All Code}
ctdabomb@ctdabomb-laptop:~$ cd /home/ctdabomb/meandmyshadow
ctdabomb@ctdabomb-laptop:~/meandmyshadow$ ./meandmyshadow
User preferences will be fetched from: /home/ctdabomb/.config/meandmyshadow/
User data will be fetched from: /home/ctdabomb/.local/share/meandmyshadow/
Data files will be fetched from: ./data/
Locale isn't set by user: en
Error while writing data to disk.
Error while writing data to disk.
Error while writing data to disk.
libpng error: IDAT: CRC error
ERROR: Can't open image file /home/ctdabomb/.local/share/meandmyshadow/themes/Pixel Castle/background.png
ERROR: Unable to load background for theme /home/ctdabomb/.local/share/meandmyshadow/themes/Pixel Castle/theme.mnmstheme
ERROR: Failed loading theme /home/ctdabomb/.local/share/meandmyshadow/themes/Pixel Castle/theme.mnmstheme
ctdabomb@ctdabomb-laptop:~/meandmyshadow$



Some people are like slinkies... not really good for anything, but you still can't help smiling when you shove them down the stairs.
ctdabomb
SuperTux Moderator
 
Posts: 1073
Joined: 13 Dec 2011, 21:21
Location: halfway there

Who is online

Users browsing this forum: No registered users and 1 guest