Vista compatiblity

Vista compatiblity

Postby artomberus » 23 May 2019, 22:33

Hello. I understand that asking for the support of the old OS is a bad tone, but I have an old laptop with Vista, and it would be nice to run a fresh version of this great game on it. :)

Now when I start the game, I get the following error:
"The procedure entry point BCryptDeriveKeyPBKDF2 could not be located in the dynamic link library bcrypt.dll."

If it’s not hard to do, is it possible to build a compatible version? If it does not require much effort. I'd be happy.
User avatar
artomberus
 
Posts: 4
Joined: 23 May 2019, 22:19
Location: Ukraine

Re: Vista compatiblity

Postby GunChleoc » 27 May 2019, 15:48

I guess the first problem will be to find somebody who both owns a Vista license and could program this.
User avatar
GunChleoc
 
Posts: 394
Joined: 20 Sep 2012, 22:45

Re: Vista compatiblity

Postby acme_pjz » 28 May 2019, 06:13

OK, I'll try to fix it. I think using XP compatible toolchain is OK.

GunChleoc {l Wrote}:I guess the first problem will be to find somebody who both owns a Vista license and could program this.


I don't have a computer with Vista, but I have a computer with XP :lol:
Some of my open source games on GitHub
User avatar
acme_pjz
 
Posts: 604
Joined: 10 Dec 2009, 15:32
Location: PeeKing, China

Re: Vista compatiblity

Postby artomberus » 28 May 2019, 07:10

acme_pjz {l Wrote}:OK, I'll try to fix it. I think using XP compatible toolchain is OK.

Thank you! I would be very grateful. Yes, usually XP-compatible software runs fine on Vista :)
User avatar
artomberus
 
Posts: 4
Joined: 23 May 2019, 22:19
Location: Ukraine

Re: Vista compatiblity

Postby acme_pjz » 28 May 2019, 13:42

I think it's fixed now (for nightly build versions). I have tested it on a XP virtual machine and it works. VC2013 and VC2015 redistributables are needed if it complains DLL not found.

Follow the instructions on Github project page to download the Windows nightly build package. Or click https://bintray.com/acmepjz/meandmyshad ... Release.7z if you are lasy :)
Some of my open source games on GitHub
User avatar
acme_pjz
 
Posts: 604
Joined: 10 Dec 2009, 15:32
Location: PeeKing, China

Re: Vista compatiblity

Postby artomberus » 28 May 2019, 14:23

acme_pjz {l Wrote}:I think it's fixed now (for nightly build versions).

I have just checked - everything works! Thank you, kind man!) Now I can complete all the levels :)
All the libraries I have installed, so it worked right away!
Thanks for the fix ;) I'm happy)

Is this fix permanent? If nothing drastically changes, then future versions of the game will be compatible, right?)
Anyway - great :)
User avatar
artomberus
 
Posts: 4
Joined: 23 May 2019, 22:19
Location: Ukraine

Who is online

Users browsing this forum: No registered users and 1 guest