Page 1 of 1

TreadMarks source GPLed

PostPosted: 07 Jul 2017, 08:53
by leilei

This happened earlier this year, forgot to make a thread about it until now.

This is a 3D tank action and racing game released in Jan 2000. The engine was really cool for its time and it's still nice now. It features dynamically deformable terrain that decimates with nice LoD almost seamlessly and the gameplay involves deforming to your advantage

Re: TreadMarks source GPLed

PostPosted: 07 Jul 2017, 10:02
by Julius
Oh, pretty cool (as it also includes the assets in the repository, not sure about the license though).

Video here:

Game description:

There is also a fork ongoing that seems to run on Linux:

Edit: Original announcement:

Re: TreadMarks source GPLed

PostPosted: 16 Jul 2017, 19:03
by sago007
Well, I did make the fork

On 32 bit Linux it is working just fine.

I have made the following changes:
  • A map is kept of all files with filenames converted to lowercase as key and the actual file as the value. This partly solves the problem with the game assuming case insensitive filenames. It does not work for wildcard searches. I would prefer to add a library like libphsyfs for this but for now it works.
  • Directory ~/.local/share/Tread Marks are created on startup. Game crashed hard without it.
  • Opening a web-url is done by invoking xdg-open or just failing silently if missing.
  • Minor changes to the build system.

64 bit have been trouble. In the beginning all textures were just pink and the game crashed on start. After having replaced a great number of "unsigned long" with "uint32_t" it does now start, textures works and you can complete a race and win.

But the following 64 bit problem still exist:
  • Intro does not work (just black)
  • Background missing in menu
  • Mini map missing
  • Arrows not drawn
  • Most projectiles not drawn.
  • Some tanks look weird
  • Fire rate on most weapons is instant
  • No damage for most weapons
  • The terrain is moving while driving (this is by far the most annoying one)

I am stuck on most of these. I am running through the code, doing some clean up to try and narrow it down.
A lot of these problems seems to be related to frame time.

I might have broken the Windows build. I tried setting up a cross compile build in Docker with MXE but QT5 proved trouble. I don't think I have broken it but without compiling, I cannot prove it.