STK 0.9.3 crashes on Win10

STK 0.9.3 crashes on Win10

Postby jona » 01 May 2018, 20:48

On Windows 10, when I try to play to STK 0.9.3, it crashes a lot of times.
My troubleshooting is that it always crashes when loading the race when I have "Graphical effects level" set to 2 or 3. When it is set to 1, I have also crashes (with the same call stack as when it crashes while loading) but this time, it is during the race and not always (I managed to finish a race :-D ).

Here is my crash report :

Call stack:

memcpy
cpu_particle_manager.cpp:CPUParticleManager::uploadAll:223
draw_calls.cpp:DrawCalls::prepareDrawCalls:704
shader_based_renderer.cpp:ShaderBasedRenderer::renderScene:247
shader_based_renderer.cpp:ShaderBasedRenderer::render:822
irr_driver.cpp:IrrDriver::update:1796
main_loop.cpp:MainLoop::run:242
main.cpp:main:1805
exe_common.inl:__scrt_common_main_seh:283
BaseThreadInitThunk
RtlUserThreadStart

Hope this helps,

Jona
jona
 
Posts: 2
Joined: 01 May 2018, 20:18

Re: STK 0.9.3 crashes on Win10

Postby Auria » 02 May 2018, 00:04

HI,

this looks a lot like a previously reported bug : https://github.com/supertuxkart/stk-code/issues/3072

this should be fixed in next release
Image
User avatar
Auria
STK Moderator
 
Posts: 2878
Joined: 07 Dec 2009, 03:52

Re: STK 0.9.3 crashes on Win10

Postby QwertyChouskie » 02 May 2018, 00:11

What model of graphics card do you have?
Not a dev, but a huge fan of STK!
User avatar
QwertyChouskie
 
Posts: 179
Joined: 29 Jun 2016, 14:57

Re: STK 0.9.3 crashes on Win10

Postby jona » 02 May 2018, 09:11

It happened on a Lenovo Thinkpad T520 with Intel HD Graphics 3000.
jona
 
Posts: 2
Joined: 01 May 2018, 20:18

Re: STK 0.9.3 crashes on Win10

Postby QwertyChouskie » 02 May 2018, 22:19

Hmm, seems like MS makes OpenGL on Windows 10 on this hardware a pain. Could you try the steps listed at https://communities.intel.com/thread/120032 and see if it helps?
Not a dev, but a huge fan of STK!
User avatar
QwertyChouskie
 
Posts: 179
Joined: 29 Jun 2016, 14:57

Re: STK 0.9.3 crashes on Win10

Postby deve » 06 May 2018, 07:08

You can disable particles (animated scenery?) in advanced options.
deve
 
Posts: 220
Joined: 23 Jan 2014, 13:45

Who is online

Users browsing this forum: Google [Bot] and 1 guest