Crash report, WIN 10 64bit

Crash report, WIN 10 64bit

Postby kriistofor » 19 Jul 2017, 17:00

Hello,

I installed STK just last week and although at first everything was running fine, soon some problems appeared.

These are the two errors that usually crash the game.

---------------------------
SuperTuxKart crashed :/
---------------------------
SuperTuxKart crashed!
Please hit Ctrl+C to copy to clipboard and signal the problem
to the developers on our forum: viewforum.php?f=16

Call stack:

---------------------------
OK
---------------------------



---------------------------
SuperTuxKart crashed :/
---------------------------
SuperTuxKart crashed!
Please hit Ctrl+C to copy to clipboard and signal the problem
to the developers on our forum: viewforum.php?f=16

Call stack:

asFreeMem
asFreeMem
asFreeMem
_libm_sse2_tan
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
asFreeMem
BaseThreadInitThunk
RtlGetAppContainerNamedObjectPath
RtlGetAppContainerNamedObjectPath
---------------------------
OK
---------------------------



They appear in local multiplayer (usually while loading a map or finishing grand prix) and in story mode (i can't get into any level - after choosing the difficulty game crashes)

i5-760
gtx 660 ti
8gb ddr3
win10 pro 64-bit



Any solutions you can offer?
kriistofor
 
Posts: 13
Joined: 18 Jul 2017, 15:35

Re: Crash report, WIN 10 64bit

Postby Auria » 21 Jul 2017, 00:46

Hi,

unfortunately the report does not really enable us to tell what went wrong, though as a first step, did you check if driver updates were available? make sure to install the latest driver from nvidia as this can sometimes be driver issues

Also, please open folder %APPDATA%/supertuxkart/0.8.2 (you can paste that in the address bar of windows explorer) and update the file stdout.log found there, please
Image
User avatar
Auria
STK Moderator
 
Posts: 2792
Joined: 07 Dec 2009, 03:52

Re: Crash report, WIN 10 64bit

Postby Arthur » 21 Jul 2017, 09:40

Auria {l Wrote}:Also, please open folder %APPDATA%/supertuxkart/0.8.2 (you can paste that in the address bar of windows explorer) and update the file stdout.log found there, please

Note that she means upload, not update. :)
Hey pal, I took an oath for justice! "In happy days or tightest tights..." or something like that.
__________________________________________________________________________
Image
User avatar
Arthur
 
Posts: 1027
Joined: 06 Dec 2009, 00:49

Re: Crash report, WIN 10 64bit

Postby kriistofor » 21 Jul 2017, 14:19

Arthur {l Wrote}:
Auria {l Wrote}:Also, please open folder %APPDATA%/supertuxkart/0.8.2 (you can paste that in the address bar of windows explorer) and update the file stdout.log found there, please

Note that she means upload, not update. :)


Just about to ask :)

here it comes

https://drive.google.com/open?id=0B8xwL ... jA1Vy1xdWc

there are three of them
kriistofor
 
Posts: 13
Joined: 18 Jul 2017, 15:35

Re: Crash report, WIN 10 64bit

Postby Auria » 22 Jul 2017, 01:44

Ok so the main error appears to be

[error ] main: Exception caught : bad allocation.


This is really hard to debug :( hiker, any idea?
Image
User avatar
Auria
STK Moderator
 
Posts: 2792
Joined: 07 Dec 2009, 03:52

Re: Crash report, WIN 10 64bit

Postby kriistofor » 22 Jul 2017, 12:55

Just to make as it easier as I can.
OS is installed on SSD,
STK on HDD
Internet connection is stable
I downgraded resolution from 2k to 1080p to 720p with no luck, also set graphics to low (even though I have a rig capable of running STK on high) - no luck again.
Checked if the game is choking the system - no, the game is running as it is supposed to run.


BUT... I downloaded many of the tracks (carefully chosen but still, so many of them that it may be the problem) and almost all of the karts.
Official 0.9.2. I downloaded addons through the game, not via web.

WIN 10 Pro x64
kriistofor
 
Posts: 13
Joined: 18 Jul 2017, 15:35

Re: Crash report, WIN 10 64bit

Postby hiker » 12 Aug 2017, 03:56

Hi,

sorry for the very late answer, I completely missed this thread.No, I don't have a good idea. The problem that we get an incomplete stack trace is known and we have a ticket for that, but no solution. Ideally running a self-compiled version would give us the details we need (and I think you asked in a different thread)

My first guess is that it might be an addon problem. I would at least try to remove all addons. Simply open %AppData%/supertuxkart, and rename the 'addons' directory to something else and then start stk and see if this works.

Cheers,
Joerg
Image
hiker
STK Moderator
 
Posts: 1414
Joined: 07 Dec 2009, 12:15
Location: Melbourne, Australia

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron