Fedora 13 svn --with-addons build error

Fedora 13 svn --with-addons build error

Postby downer » 10 Sep 2010, 01:28

I had to use this to compile the svn on Fedora 13 for addons:
{l Code}: {l Select All Code}
LIBS=-lpthread ./configure --with-addons

or I get this error:
{l Code}: {l Select All Code}
/usr/bin/ld: addons_loading.o: undefined reference to symbol 'pthread_create@@GLIBC_2.1'
/usr/bin/ld: note: 'pthread_create@@GLIBC_2.1' is defined in DSO /lib/libpthread.so.0 so try adding it to the linker command line
/lib/libpthread.so.0: could not read symbols: Invalid operation
collect2: ld returned 1 exit status

I'm not sure if this is the correct way to fix this error. After I add new characters through addons, STK crashes, but has the characters added.
It might not matter, but I added irrlicht 1.7.1 for a Fedora Rawhide RPM from http://rpm.pbone.net/.

I'm mostly curious because the track I'm working on will probably be an addon track.
"...curiosity saved the mouse." -Deceth
User avatar
downer
 
Posts: 38
Joined: 19 Jan 2010, 05:05
Location: USA

Re: Fedora 13 svn --with-addons build error

Postby hiker » 10 Sep 2010, 01:42

Hi,

the add-on manager is highly experimental (and will most likely not even be included in the next release). While xapantu is happy about bug reports, I would for now recommend to disable this and wait till we work on that after the next release.

Cheers,
Joerg
hiker
 
Posts: 1435
Joined: 07 Dec 2009, 12:15
Location: Melbourne, Australia

Re: Fedora 13 svn --with-addons build error

Postby xapantu » 10 Sep 2010, 18:38

Hi,
Yes, the addons manager is really experimental, and to be honnest, I am not an expert with the autotools... So, I don't know what it doesn't work, since pthread should be installed by default...

I will try to build it on Fedora 13 in the next week.

I'm mostly curious because the track I'm working on will probably be an addon track.

cool :)
xapantu
 
Posts: 283
Joined: 07 Dec 2009, 17:30

Re: Fedora 13 svn --with-addons build error

Postby stked » 10 Sep 2010, 23:34

It's nice to see someone besides me uses Fedora.

what kind of track?
Gaming with Netbooks blog
gamingwithnetbooks.blogspot.com

STK editor website
stked.webs.com
User avatar
stked
 
Posts: 141
Joined: 07 Dec 2009, 16:42

Re: Fedora 13 svn --with-addons build error

Postby downer » 11 Sep 2010, 02:26

A little off topic, but its an Icy Cave track, and still needs a lot of work. Several month's worth of weekends at least! I'm back to working on it after a few months break.
http://forum.freegamedev.net/viewtopic.php?f=18&t=282
I'm gonna try and keep tris down to 20K, because that's what my computer can run right now at a decent frame rate with the open source nVidia Gallium3D drivers on Fedora Rawhide. Now if I can just figure out how to speed up Blender by splitting up the map or something, but until then I'll use Fedora 13 and nVidia's binary drivers.
"...curiosity saved the mouse." -Deceth
User avatar
downer
 
Posts: 38
Joined: 19 Jan 2010, 05:05
Location: USA

Re: Fedora 13 svn --with-addons build error

Postby downer » 14 Sep 2010, 17:35

I just started using Irrlicht compiled from svn since Fedora kept trying to downgrade it to 1.6.1, and I got another error.
I also have to add "LIBS=-lXcursor" or comment out "#define _IRR_LINUX_XCURSOR_" in /irrlicht/include/IrrCompileConfig.h for Fedora 13.
Otherwise I get this error when configuring STK:
{l Code}: {l Select All Code}
/usr/local/lib/libIrrlicht.so: undefined reference to `XcursorImageLoadCursor'
/usr/local/lib/libIrrlicht.so: undefined reference to `XcursorImageCreate'
/usr/local/lib/libIrrlicht.so: undefined reference to `XcursorImageDestroy'

The configure command for me on Fedora with compiled Irrlicht and addons is:
{l Code}: {l Select All Code}
LIBS="-lpthread -lXcursor" ./configure --with-addon
"...curiosity saved the mouse." -Deceth
User avatar
downer
 
Posts: 38
Joined: 19 Jan 2010, 05:05
Location: USA

Re: Fedora 13 svn --with-addons build error

Postby hiker » 15 Sep 2010, 03:12

downer {l Wrote}:I just started using Irrlicht compiled from svn since Fedora kept trying to downgrade it to 1.6.1, and I got another error.
I also have to add "LIBS=-lXcursor" or comment out "#define _IRR_LINUX_XCURSOR_" in /irrlicht/include/IrrCompileConfig.h for Fedor

What irrlicht version are you using? The recommended version is 1.7.1 (best the current svn version from the appropriate branch to get additional bug fixes). The XCursor support was added on irrlicht trunk, and we have not ported STK to trunk/irrlicht 1.8 at all. So this will be fixed once we switch. For now I am going to remove support for irrlicht 1.8, since I would need some feedback from package maintainer to see how this should be handled - any feedback from anyone? Can we assume that libXcursor is available if irrlicht is compiled with it? And if libXcursor is not available, can we just assume that we are fine not using this flag?

A patch as always is welcome :)

Cheers,
Joerg

Edit: URL for stable irrlicht branch to use: https://irrlicht.svn.sourceforge.net/sv ... leases/1.7
hiker
 
Posts: 1435
Joined: 07 Dec 2009, 12:15
Location: Melbourne, Australia

Re: Fedora 13 svn --with-addons build error

Postby downer » 15 Sep 2010, 17:50

I was using 1.8 without realizing it, but seems to work ok otherwise.
svn co https://irrlicht.svn.sourceforge.net/svnroot/irrlicht ./irrlicht
"...curiosity saved the mouse." -Deceth
User avatar
downer
 
Posts: 38
Joined: 19 Jan 2010, 05:05
Location: USA

Re: Fedora 13 svn --with-addons build error

Postby hiker » 16 Sep 2010, 00:25

downer {l Wrote}:I was using 1.8 without realizing it, but seems to work ok otherwise.
svn co https://irrlicht.svn.sourceforge.net/svnroot/irrlicht ./irrlicht

Thanks for the tests - it is pretty much what I expected, but being close to another alpha release I want to make sure that we don't start getting bug reports which are ultimately caused by something else ;)

Cheers,
Joerg
hiker
 
Posts: 1435
Joined: 07 Dec 2009, 12:15
Location: Melbourne, Australia

Re: Fedora 13 svn --with-addons build error

Postby downer » 16 Sep 2010, 19:34

Only makes sense to only use 1.7.1 for now.
I had to make a symbolic link from /usr/local/lib/libIrrlicht to /usr/lib to get STK to configure in Fedora.
Edit:
Only for the svn, the RPM already has symbolic links.
{l Code}: {l Select All Code}
ln -s /usr/local/lib/libIrrlicht.so.1.7.0-SVN /usr/lib/libIrrlicht.so.1.7

The svn for 1.7.1 works better for me, because I can't build the Irrlicht demo with the normal sdk.

I was confused earlier about Irrlicht 1.8, because the executable is labeled just like the 1.7.1 svn.
"...curiosity saved the mouse." -Deceth
User avatar
downer
 
Posts: 38
Joined: 19 Jan 2010, 05:05
Location: USA

Who is online

Users browsing this forum: Google [Bot] and 1 guest