Page 1 of 1

No display on stk

PostPosted: 21 Feb 2010, 18:00
by nicolas
Hi there,

My name is Nicolas and this is my first post. I'm completely new to Linux world, so please, treat me as a complete noob, if ever you decide to answer my question.
And here is my question:
I have recently installed SuperTuxKart and really enjoyed it.
After a while, I decided to change the display resolution (from wich resolution to which resolution? I can't remember, just clicked randomly to try them out)
The screen went black. The game went on, I could still hear the music and the game sounds when pressing keys, but there was nothing more displayed on my screen (apart from a message automatically generated by my screen, explaining to me that somehow the frequency, resolution or some other technical stuff is not supported).
So here I am, I really want to play that game, but it just won't display. Managed to turn it off and my ubuntu still works fine, but as soon as I start the game, the screen goes black again.
I heard the linux fan community is nice, caring and helpful, so I hope I'll get an answer.

Btw, I already to tried to uninstall and then reinstall the game, but the problem remains.

Thanks in advance,

Re: No display on stk

PostPosted: 21 Feb 2010, 21:56
by Arthur
Hi Nicolas, I guess uninstalling SuperTuxKart didn't get rid of your configuration file. I assume you have SuperTuxKart 0.6.x installed, in which case the offending configuration file can be found following these instructions:
1. Go to your home directory with the file browser.
2. Make sure you see hidden directories. In Ubuntu's file browser you can toggle it on/off using CTRL + H.
3. Go into the folder named .supertuxkart and delete or modify the config file found there. If you delete it, a new configuration file will be made automatically when starting STK again.

I hope this will solve your problem. :)

Re: No display on stk

PostPosted: 22 Feb 2010, 00:26
by nicolas
Hi Arthur,

That worked perfectly!
Thank you very much!!!


Re: No display on stk

PostPosted: 22 Feb 2010, 00:33
by Arthur
I'm glad you got it solved. :)

Just a small tip: if you're using Ubuntu and the package manager named Synaptic, you can click on a package and then choose whether to remove the package or remove it completely; the latter will delete configuration files as well.