Missing library objects when loading a track into Blender

Missing library objects when loading a track into Blender

Postby eltomito » 03 Oct 2019, 07:59

Hi!

I was trying to mess around with the new Canyon 42 track a little but when I loaded it into Blender, I got a lot of messages like this in the command line:

Warning: Cannot find lib '/home/tomas/src/supertuxkart/stk-assets/library/nature/stklib_cactus_a/stklib_cactus_a.blend'
Warning: LIB: Object: 'stklib_cactus_a_main' missing from '/home/tomas/src/supertuxkart/stk-assets/library/nature/stklib_cactus_a/stklib_cactus_a.blend', parent '<direct>'
Warning: LIB: Mesh: 'cactus.006' missing from '/home/tomas/src/supertuxkart/stk-assets/library/nature/stklib_cactus_a/stklib_cactus_a.blend', parent '<direct>'

The weird thing is that is seems to be asking for the stk-assets/library/nature/ subdirectory but no such thing exists nor did I find it in the SVN assets repo. Other messages like that ask for such subdirectories as "industry" or "vehicles" but none of them exists anywhere that I could find. What am I doing wrong?

Thank you for your advice!
eltomito
 
Posts: 125
Joined: 15 Mar 2013, 09:25

Re: Missing library objects when loading a track into Blende

Postby eltomito » 03 Oct 2019, 14:26

Oh, there's a difference between
http://svn.code.sf.net/p/supertuxkart/code/stk-assets/library
and
http://svn.code.sf.net/p/supertuxkart/code/media/trunk/library

I guess I should use the latter for track modding, right?
eltomito
 
Posts: 125
Joined: 15 Mar 2013, 09:25

Re: Missing library objects when loading a track into Blende

Postby benau » 03 Oct 2019, 17:13

yes the media one is for making track in blender
Image
benau
STK Moderator
 
Posts: 136
Joined: 08 Dec 2015, 17:32

Who is online

Users browsing this forum: MSN [Bot] and 1 guest