custom STK server, cannot connect

custom STK server, cannot connect

Postby jin » 04 Sep 2019, 05:01

Hi,
I tried to set up a STK server on my computer (compiled from git 137e9dd, SERVER_ONLY=ON). But I cannot connect to it even using my phone (connect to the same router). I can, however, connect to the server on my computer with another instance of STK (both IPv4 (127.0.0.1:xxxx) and IPv6). The log of the server shows some error message:
{l Code}: {l Select All Code}
Tue Sep  3 22:47:53 2019 [info   ] HTTPRequest: Sending userid=149303&token=************************&address=xxxx&port=2759&private_port=2759&name=xxxx&max_players=10&difficulty=3&game_mode=6&password=*&version=6&address_ipv6=260xxxx to https://online.supertuxkart.net/api/v2/server/create/
Tue Sep  3 22:47:56 2019 [info   ] ServerLobby: Server 55312 is now online.
Tue Sep  3 22:48:30 2019 [error  ] XMLRequest::afterOperation: curl_easy_perform() failed: Couldn't connect to server
Tue Sep  3 22:48:30 2019 [error  ] ServerLobby: Poll server request failed: 
Tue Sep  3 22:49:05 2019 [error  ] XMLRequest::afterOperation: curl_easy_perform() failed: Couldn't connect to server
Tue Sep  3 22:49:05 2019 [error  ] ServerLobby: Poll server request failed:
Tue Sep  3 22:49:40 2019 [error  ] XMLRequest::afterOperation: curl_easy_perform() failed: Couldn't connect to server
Tue Sep  3 22:49:40 2019 [error  ] ServerLobby: Poll server request failed:


When starting the server, the log is:
{l Code}: {l Select All Code}
Tue Sep  3 22:52:53 2019 [info   ] STKHost: Server port is 2759
Tue Sep  3 22:52:53 2019 [info   ] ServerLobby: Resetting the server to its initial state.
Tue Sep  3 22:52:53 2019 [info   ] ProtocolManager: A 11ServerLobby protocol has been started.
Tue Sep  3 22:52:53 2019 [info   ] main: Creating a WAN server 'xxxx'.
Tue Sep  3 22:52:53 2019 [warn   ] LayoutManager: Widget 'timeout-message' has a height of 0 (left_space = 0, fraction = 1.000000, max_width = )

Tue Sep  3 22:52:53 2019 [info   ] STKHost: Listening has been started.
Tue Sep  3 22:52:53 2019 [info   ] ServerLobby: Public server address xxxx:2759
Tue Sep  3 22:52:53 2019 [info   ] ServerLobby: Public IPv6 server address 260xxxx
Tue Sep  3 22:52:53 2019 [info   ] HTTPRequest: Sending userid=149303&token=************************&address=xxxx&port=2759&private_port=2759&name=xxxx&max_players=10&difficulty=3&game_mode=6&password=*&version=6&address_ipv6=2xxxx to https://online.supertuxkart.net/api/v2/server/create/
Tue Sep  3 22:52:53 2019 [info   ] HTTPRequest: Sending userid=149303&token=************************&visitingid=149303 to https://online.supertuxkart.net/api/v2/user/get-friends-list/
Tue Sep  3 22:52:53 2019 [info   ] ServerLobby: Server 55313 is now online.


I am on Linux: CentOS Linux release 7.6.1810 (Core)
Port-forwarding was set on the router: TCP 2759->2759, UDP 2759->2759

Any idea? Thank you!
jin
 
Posts: 18
Joined: 29 May 2013, 17:53

Who is online

Users browsing this forum: No registered users and 1 guest