1.0.0 version totally doesn't work.

1.0.0 version totally doesn't work.

Postby laol-tomsk » 25 Apr 2019, 06:14

I've downloaded STK 1.0.0 and found that it totally doesn't work. Every time when it's needed to choose a kart, it becames Not Responding. When I open single-player mode, list of installed karts is visible, but STK is Not Responding. When I open multi-player (not networked), list of installed kart is visible, but STK becames Not Responding when I press 'fire' to choose a kart. When I open Tutorial, STK becames Not Responding. Same for when I open Story Mode, but there I can see only black screen with fps in the corner.

I can't play game, only viewing servers, changing settings, and installing Add-Ons.

STK 0.10-beta had worked perfectly before I've installed 1.0.0, but now it behaves in the same way. I haven't installed 0.10-rc1. stdout.log files contain no intresting info (I can attach it if you say it's needed, though).
laol-tomsk
 
Posts: 3
Joined: 25 Apr 2019, 06:03

Re: 1.0.0 version totally doesn't work.

Postby Alayan » 25 Apr 2019, 16:53

I don't know what the problem is and hope it can be solved, but it's definitely on your end of things, your computer is having an issue, not STK. That 0.10-beta worked before and doesn't now is the most obvious proof of it, as it doesn't use the same config folder as 1.0 so there is no reason whatsoever for it to break after you installed 1.0.
Alayan
STK Moderator
 
Posts: 206
Joined: 25 Mar 2012, 22:11

Re: 1.0.0 version totally doesn't work.

Postby QwertyChouskie » 25 Apr 2019, 21:34

Try disabling Texture Compression in the graphics settings.
Not an official dev, but a huge fan of STK!
User avatar
QwertyChouskie
 
Posts: 368
Joined: 29 Jun 2016, 14:57

Re: 1.0.0 version totally doesn't work.

Postby laol-tomsk » 26 Apr 2019, 05:18

QwertyChouskie {l Wrote}:Try disabling Texture Compression in the graphics settings.

It didn't help.
laol-tomsk
 
Posts: 3
Joined: 25 Apr 2019, 06:03

Re: 1.0.0 version totally doesn't work.

Postby QwertyChouskie » 26 Apr 2019, 19:54

Do you have any addons installed?
Not an official dev, but a huge fan of STK!
User avatar
QwertyChouskie
 
Posts: 368
Joined: 29 Jun 2016, 14:57

Re: 1.0.0 version totally doesn't work.

Postby laol-tomsk » 28 Apr 2019, 14:18

QwertyChouskie {l Wrote}:Do you have any addons installed?

No.There's no "karts" and "tracks" subfolders in "addons" folder, and all addons have installed="false" in addons_installed.xml.
laol-tomsk
 
Posts: 3
Joined: 25 Apr 2019, 06:03

Re: 1.0.0 version totally doesn't work.

Postby Auria » 28 Apr 2019, 23:00

I don't know if I'll be able to help, but I would suggest to include the usual information : which OS are you using, which GPU, which driver (and version).
Image
User avatar
Auria
STK Moderator
 
Posts: 2975
Joined: 07 Dec 2009, 03:52

Re: 1.0.0 version totally doesn't work.

Postby Paulo » 12 Aug 2019, 19:52

It seems that the problem was the Intel video driver.
I downloaded and installed a new version and now STK 1.0 is working as expected, including lan game :)
Thank you all the STK team for your work.

The problematic driver is this:
{l Code}: {l Select All Code}
Intel(R) HD Graphics 4000

Report Date: Monday, August 12, 2019
Report Time [hh:mm:ss]: 3:11:07 PM
Driver Version: 10.18.10.4358
Operating System: Windows* 10 Home (10.0.18362)
Default Language: Portuguese (Brazil)
Installed DirectX* Version: 12.0
Supported DirectX* Version: 11.0
Shader Version: 5.0
OpenGL* Version: 4.0
OpenCL* Version: 1.2
Physical Memory: 3956 MB
Processor: Intel(R) Core(TM) i5-3317U CPU @ 1.70GHz
Processor Speed: 1696 MHz
Vendor ID: 8086
Device ID: 0166
Device Revision: 09

* Processor Graphics Information *

Processor Graphics in Use: Intel(R) HD Graphics 4000
Video BIOS: 0.0
Current Resolution: 1366 x 768


The new driver is this, all working ok:
{l Code}: {l Select All Code}
Intel(R) HD Graphics 4000

Report Date: Monday, August 12, 2019
Report Time [hh:mm:ss]: 3:43:12 PM
Driver Version: 10.18.10.5069
Operating System: Windows* 10 Home (10.0.18362)
Default Language: Portuguese (Brazil)
Installed DirectX* Version: 12.0
Supported DirectX* Version: 11.0
Shader Version: 5.0
OpenGL* Version: 4.0
OpenCL* Version: 1.2
Physical Memory: 3956 MB
Processor: Intel(R) Core(TM) i5-3317U CPU @ 1.70GHz
Processor Speed: 1696 MHz
Vendor ID: 8086
Device ID: 0166
Device Revision: 09

* Processor Graphics Information *

Processor Graphics in Use: Intel(R) HD Graphics 4000
Video BIOS: 0.0
Current Resolution: 1366 x 768
Paulo
 
Posts: 1
Joined: 12 Aug 2019, 18:22

Who is online

Users browsing this forum: No registered users and 1 guest